summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick M2022-05-16 20:16:50 +0200
committerPatrick M2022-05-16 20:16:50 +0200
commit242a082e994e7d0973f35b6c720a40fe46b54080 (patch)
tree85d0195ed360d46084276959610c227189fa2bd2
downloadaur-242a082e994e7d0973f35b6c720a40fe46b54080.tar.gz
Initial commit (v1.0.5)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5381f9a1164
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fuchsia-cursor
+ pkgdesc = Open source port of FuchsiaOS's cursors for Linux
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/ful1e5/fuchsia-cursor
+ arch = any
+ license = AGPL
+ source = https://github.com/ful1e5/fuchsia-cursor/releases/download/v1.0.5/Fuchsia.tar.gz
+ source = https://github.com/ful1e5/fuchsia-cursor/releases/download/v1.0.5/Fuchsia-Pop.tar.gz
+ source = https://github.com/ful1e5/fuchsia-cursor/releases/download/v1.0.5/Fuchsia-Red.tar.gz
+ sha256sums = 686c74f62b35b6bc6c955ffbede4e9dd190104c009d6a4ea6a0a2f8e1db9b642
+ sha256sums = 43fd9e83ae690a51722389ae9fb8c850eef48aa9026e5e1818f6b4c9b652a643
+ sha256sums = 7d088b2cfb529af204b8deed610b24c8a40af4ed26d3b6d6a9fa463385cec804
+
+pkgname = fuchsia-cursor
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..688266f978c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Patrick M. <aur at patrickmang dot de>
+
+pkgname=fuchsia-cursor
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="Open source port of FuchsiaOS's cursors for Linux"
+arch=('any')
+url='https://github.com/ful1e5/fuchsia-cursor'
+license=('AGPL')
+source=("https://github.com/ful1e5/${pkgname}/releases/download/v${pkgver}/Fuchsia.tar.gz"
+ "https://github.com/ful1e5/${pkgname}/releases/download/v${pkgver}/Fuchsia-Pop.tar.gz"
+ "https://github.com/ful1e5/${pkgname}/releases/download/v${pkgver}/Fuchsia-Red.tar.gz")
+sha256sums=('686c74f62b35b6bc6c955ffbede4e9dd190104c009d6a4ea6a0a2f8e1db9b642'
+ '43fd9e83ae690a51722389ae9fb8c850eef48aa9026e5e1818f6b4c9b652a643'
+ '7d088b2cfb529af204b8deed610b24c8a40af4ed26d3b6d6a9fa463385cec804')
+
+package() {
+ install -Ddm755 "${pkgdir}/usr/share/icons"
+ cp -dr --no-preserve=ownership "Fuchsia" "${pkgdir}/usr/share/icons/"
+ cp -dr --no-preserve=ownership "Fuchsia-Pop!" "${pkgdir}/usr/share/icons/"
+ cp -dr --no-preserve=ownership "Fuchsia-Red" "${pkgdir}/usr/share/icons/"
+}