summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMrViK2018-07-18 00:41:05 +0200
committerMrViK2018-07-18 00:41:05 +0200
commit2452997d16098e44889b26a596b45b5f3414f52b (patch)
tree8a0cd202b1449ef54ed40b26e9fe0e24104b814e
downloadaur-2452997d16098e44889b26a596b45b5f3414f52b.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD23
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c805c61826d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pakku-gui
+ pkgdesc = GTK frontend for pakku
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://gitlab.com/mrvik/pakku-gui
+ arch = any
+ license = GPL2
+ depends = python
+ depends = python-gobject
+ depends = gtk3
+ depends = pakku
+ provides = pakku-gui
+ conflicts = pakku-gui-git
+ source = https://gitlab.com/mrvik/pakku-gui/-/archive/0.1.0/pakku-gui-0.1.0.tar
+ sha256sums = 39dd778e713be29c593c9c8e82ced89b09d1264bd260e92cb6ba96bf2174565a
+
+pkgname = pakku-gui
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7f97a6eff873
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3f73d42f9b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=pakku-gui
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="GTK frontend for pakku"
+arch=("any") # If pakku and python can be installed, this too
+url="https://gitlab.com/mrvik/pakku-gui"
+license=("GPL2")
+depends=("python" "python-gobject" "gtk3" "pakku")
+source=("https://gitlab.com/mrvik/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar")
+provides=($pkgname)
+conflicts=($pkgname-git)
+sha256sums=("9ca9afb4095d09a39377b98486bb93c97c4dd07de6c5482e7f9e55fe0a32432f")
+
+package(){
+ _libdir=$pkgdir/usr/lib/$pkgname
+ _applications=$pkgdir/usr/share/applications
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p "$_libdir" "$_applications" "$pkgdir/usr/bin"
+ cp *.py "$_libdir"
+ cp "$pkgname.desktop" "$_applications"
+ chmod +x "$_libdir/main.py"
+ ln -s "/usr/lib/$pkgname/main.py" "$pkgdir/usr/bin/$pkgname"
+}