summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-10-15 17:14:36 +0200
committerM0Rf302019-10-15 17:14:36 +0200
commit247154f036152db0be3a7e8869e8dafc233ca75c (patch)
treeb3d9e37bba3b8cdcce03d239811b9eff8fac5d0d
parentdad25ad78e20ed4bb295bb7b00690dd53324b03a (diff)
downloadaur-247154f036152db0be3a7e8869e8dafc233ca75c.tar.gz
mycroft-core: gpasswd typo fixed
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--mycroft-core.install4
-rw-r--r--mycroft.tmpfiles4
4 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f159e3748c3..531ae212acb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -35,7 +35,7 @@ pkgbase = mycroft-core
source = mycroft.service
source = mycroft.pulseaudio
md5sums = 04ec4428ad8ee3787e798bcd5a7ed23a
- md5sums = 5fafd69eb177046827b9cb93c91e3802
+ md5sums = b09b8ac1a4c1fbb17c79bde8d6520ea1
md5sums = f4b41cc9e1a7308c8833f0f7804d8c02
md5sums = a587888fcaf792ab9ceb6c698bb03ac3
md5sums = ffd5e294798abaa35bb79f2b1afd40e1
diff --git a/PKGBUILD b/PKGBUILD
index 66ccb7c58861..1fd3e339990b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -62,13 +62,16 @@ package() {
pip install https://github.com/JarbasAl/py_mplayer/archive/master.zip
sed -i 's/^VIRTUAL_ENV=.*/VIRTUAL_ENV="\/usr\/share\/mycroft-core\/.venv"/g' .venv/bin/activate
rm .venv/bin/activate.{fish,csh}
+
+ # Cleanup
find . -name "*.py[co]" -o -name __pycache__ -exec rm -rf {} +
- install -D -m644 "${srcdir}/mycroft.pulseaudio" "${pkgdir}/usr/share/mycroft-core/pulse-client.conf"
+ # Pulseaudio Workaround (any suggestion is well accepted)
+ install -D -m644 "${srcdir}/mycroft.pulseaudio" "${pkgdir}/usr/share/mycroft-core/pulse-client.conf"
}
md5sums=('04ec4428ad8ee3787e798bcd5a7ed23a'
- '5fafd69eb177046827b9cb93c91e3802'
+ 'b09b8ac1a4c1fbb17c79bde8d6520ea1'
'f4b41cc9e1a7308c8833f0f7804d8c02'
'a587888fcaf792ab9ceb6c698bb03ac3'
'ffd5e294798abaa35bb79f2b1afd40e1')
diff --git a/mycroft-core.install b/mycroft-core.install
index 01ad4bf02bbe..94843fcb56c6 100644
--- a/mycroft-core.install
+++ b/mycroft-core.install
@@ -1,6 +1,8 @@
post_install() {
- echo "====> Please add mycroft user to audio group"
+ echo "====> Please add mycroft user to these groups"
echo "==== sudo gpasswd -a mycroft audio"
+ echo "==== sudo gpasswd -a mycroft dbus"
+ echo "==== sudo gpasswd -a mycroft network"
echo "====> Add this line to your default.pa PulseAudio file configuration"
echo "==== load-module module-native-protocol-unix auth-anonymous=1 socket=/tmp/pulse-socket"
echo "====> Read instructions under /usr/share/mycroft-core/pulseaudio-client.conf"
diff --git a/mycroft.tmpfiles b/mycroft.tmpfiles
index a376b96de142..e1d5f2d75812 100644
--- a/mycroft.tmpfiles
+++ b/mycroft.tmpfiles
@@ -1,6 +1,6 @@
-d /usr/share/mycroft-core 0755 mycroft mycroft
+Z /usr/share/mycroft-core 0755 mycroft mycroft
d /var/lib/mycroft 0755 mycroft mycroft
-d /var/lib/mycroft/ 0755 mycroft mycroft
d /var/log/mycroft 0755 mycroft mycroft
d /opt/mycroft/ 0755 mycroft mycroft
d /tmp/mycroft/ 0755 mycroft mycroft
+f /var/tmp/mycroft_web_cache.json 0755 mycroft mycroft