summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-05-26 10:20:14 +0200
committerNicola Murino2020-05-26 10:20:14 +0200
commit24922c357fd2750f867f57782998c0a034cf77f9 (patch)
tree2ea89c29ab4cf6d0deb79823d59c27d02b25654e
parent6e7804befcbd02d400949692f4495af268a38061 (diff)
downloadaur-24922c357fd2750f867f57782998c0a034cf77f9.tar.gz
update to 2.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b5a816cef48..d1935ee0612f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-openh264
pkgdesc = OpenH264 is a codec library which supports H.264 encoding and decoding (mingw-w64)
- pkgver = 2.1.0
+ pkgver = 2.1.1
pkgrel = 1
url = http://www.openh264.org/
arch = any
@@ -11,8 +11,8 @@ pkgbase = mingw-w64-openh264
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/cisco/openh264/archive/v2.1.0.tar.gz
- sha256sums = 27f185d478066bad0c8837f4554cd8d69cca1d55d5f3dc6a43a8cef1fe6c005f
+ source = https://github.com/cisco/openh264/archive/v2.1.1.tar.gz
+ sha256sums = af173e90fce65f80722fa894e1af0d6b07572292e76de7b65273df4c0a8be678
pkgname = mingw-w64-openh264
diff --git a/PKGBUILD b/PKGBUILD
index 803aace7ecde..ccc120136849 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-openh264
-pkgver=2.1.0
+pkgver=2.1.1
pkgrel=1
pkgdesc="OpenH264 is a codec library which supports H.264 encoding and decoding (mingw-w64)"
arch=(any)
@@ -10,7 +10,7 @@ depends=('mingw-w64-gcc')
makedepends=('nasm' 'mingw-w64-make')
options=(!strip !buildflags staticlibs)
source=("https://github.com/cisco/openh264/archive/v${pkgver}.tar.gz")
-sha256sums=('27f185d478066bad0c8837f4554cd8d69cca1d55d5f3dc6a43a8cef1fe6c005f')
+sha256sums=('af173e90fce65f80722fa894e1af0d6b07572292e76de7b65273df4c0a8be678')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -49,6 +49,9 @@ package() {
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
${_arch}-strip --strip-all "$pkgdir"/usr/${_arch}/bin/*.exe
+ if [[ $NO_EXECUTABLES ]]; then
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete
+ fi
done
}