summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-05-14 18:29:08 +0200
committerbartus2021-05-14 18:29:08 +0200
commit249b78b646f0ad7e05119e9f169aaff9d837d812 (patch)
treea58dbbba4367708dea22dc6c49f5e3684b2ac767
parent18339af9d3868250d2735568371e8352bdd8be38 (diff)
downloadaur-249b78b646f0ad7e05119e9f169aaff9d837d812.tar.gz
Fix build against openexr:3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--openexr3.patch57
3 files changed, 68 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59a4708a28bb..abdd74e04dcc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blender-fracture_modifier-git
pkgdesc = Development version of Blenders fracture_modifier branch
- pkgver = 2.79.r70678.g233ad61cb8d
- pkgrel = 2
+ pkgver = 2.79.r70679.g32fef3040fe
+ pkgrel = 1
url = https://blender.org/
arch = i686
arch = x86_64
@@ -53,6 +53,7 @@ pkgbase = blender-fracture_modifier-git
source = python3.9_2.patch
source = openvdb7.patch
source = openvdb8.patch
+ source = openexr3.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -68,11 +69,12 @@ pkgbase = blender-fracture_modifier-git
sha256sums = 5ff48d0e35025f21ee45274b56d1788b2e1768fa4d86b5032a40941057695176
sha256sums = f4fea95b9d27fb5c30a13cd57ae22d8f3091d456719377e28572091793e941c2
sha256sums = 229853b98bb62e1dec835aea6b2eab4c3dabbc8be591206573a3c1b85f10be59
- sha256sums = e959c2ae13baa35e9ee6d9ff8f30fea55a60ccd59a0b8d047df134aee4b5424e
+ sha256sums = 350063cd4f234565bd928a356b4e5f65cf37fc1377904a08bf60f7010c88740b
sha256sums = d106248d55045f5ef913bf6243ad74a76f6282264d9ee4c9b87ec4a3d2e2064b
sha256sums = b2a2bc5de8d3b730e49d1f50cb025c1dfdbcb66c58ead573322585b6a887d3a7
sha256sums = c4079c4c142516d9cd476f5a3cafddf4068f0950c3c11ea4da9cf999c5ccc1f9
sha256sums = edfd784f8497417660c0b9fdc97893fd0d77764d0bc10f4cb92a9082f41bae75
+ sha256sums = 8e28b28679c67ce589558468d5d912321b345dbbe46c80b359a1a38417ba2ed2
pkgname = blender-fracture_modifier-git
diff --git a/PKGBUILD b/PKGBUILD
index 4d2d0662161b..a64a9c1991be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,9 +15,9 @@ _suffix=${_branch}
((DISABLE_CUDA)) && optdepends+=('cuda: CUDA support in Cycles') || makedepends+=('cuda')
pkgname=blender-${_suffix}-git
-pkgver=2.79.r70678.g233ad61cb8d
+pkgver=2.79.r70679.g32fef3040fe
_blenver=${pkgver:0:4}
-pkgrel=2
+pkgrel=1
pkgdesc="Development version of Blenders ${_branch} branch"
arch=('i686' 'x86_64')
url="https://blender.org/"
@@ -53,6 +53,7 @@ source=("git://git.blender.org/blender.git${_fragment}"
'python3.9_2.patch' # ::https://git.blender.org/gitweb/gitweb.cgi/blender.git/patch/5edba9b42f684bf8b99894bb6988e7f46180e12c
openvdb7.patch
openvdb8.patch # ::https://git.blender.org/gitweb/gitweb.cgi/blender.git/patch/37889011070ff2ec52159690f652238d2b325185
+ openexr3.patch
)
sha256sums=('SKIP'
'SKIP'
@@ -73,7 +74,8 @@ sha256sums=('SKIP'
'd106248d55045f5ef913bf6243ad74a76f6282264d9ee4c9b87ec4a3d2e2064b'
'b2a2bc5de8d3b730e49d1f50cb025c1dfdbcb66c58ead573322585b6a887d3a7'
'c4079c4c142516d9cd476f5a3cafddf4068f0950c3c11ea4da9cf999c5ccc1f9'
- 'edfd784f8497417660c0b9fdc97893fd0d77764d0bc10f4cb92a9082f41bae75')
+ 'edfd784f8497417660c0b9fdc97893fd0d77764d0bc10f4cb92a9082f41bae75'
+ '8e28b28679c67ce589558468d5d912321b345dbbe46c80b359a1a38417ba2ed2')
pkgver() {
blender_version=$(grep -Po "BLENDER_VERSION\s+\K[0-9]{3}" "$srcdir"/blender/source/blender/blenkernel/BKE_blender_version.h)
@@ -94,7 +96,7 @@ prepare() {
if [[ -v _suffix ]]; then
git apply -v <(sed "s/@@_suffix@@/${_suffix}/g" "${srcdir}/addon_path.patch")
fi
- git -C "$srcdir/blender" apply -v "${srcdir}"/{gcc{8,9},ffmpeg,openvdb{,7,8},collada1668,oiio-2.0,Cleanup-use-PyImport_GetModuleDict}.patch
+ git -C "$srcdir/blender" apply -v "${srcdir}"/{gcc{8,9},ffmpeg,openvdb{,7,8},collada1668,oiio-2.0,Cleanup-use-PyImport_GetModuleDict,openexr3}.patch
git -C "$srcdir/blender" apply -v "${srcdir}"/python3.{8,9,9_2}.patch
}
diff --git a/openexr3.patch b/openexr3.patch
new file mode 100644
index 000000000000..11cf422ef55e
--- /dev/null
+++ b/openexr3.patch
@@ -0,0 +1,57 @@
+diff --git a/build_files/cmake/Modules/FindOpenEXR.cmake b/build_files/cmake/Modules/FindOpenEXR.cmake
+index 090f80b8df7..a2f7b4c622b 100644
+--- a/build_files/cmake/Modules/FindOpenEXR.cmake
++++ b/build_files/cmake/Modules/FindOpenEXR.cmake
+@@ -34,11 +34,10 @@ ENDIF()
+ SET(_openexr_libs_ver_init "2.0")
+
+ SET(_openexr_FIND_COMPONENTS
+- Half
+ Iex
+- IlmImf
+- IlmThread
+ Imath
++ OpenEXR
++ IlmThread
+ )
+
+ SET(_openexr_SEARCH_DIRS
+@@ -120,7 +119,7 @@ FIND_PACKAGE_HANDLE_STANDARD_ARGS(OpenEXR DEFAULT_MSG
+ IF(OPENEXR_FOUND)
+ SET(OPENEXR_LIBRARIES ${_openexr_LIBRARIES})
+ # Both include paths are needed because of dummy OSL headers mixing #include <OpenEXR/foo.h> and #include <foo.h> :(
+- SET(OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR} ${OPENEXR_INCLUDE_DIR}/OpenEXR)
++ SET(OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR} ${OPENEXR_INCLUDE_DIR}/OpenEXR ${OPENEXR_INCLUDE_DIR}/Imath)
+ ENDIF()
+
+ MARK_AS_ADVANCED(
+diff --git a/source/blender/imbuf/intern/openexr/openexr_api.cpp b/source/blender/imbuf/intern/openexr/openexr_api.cpp
+index b6e93a5111b..7d88edb43fd 100644
+--- a/source/blender/imbuf/intern/openexr/openexr_api.cpp
++++ b/source/blender/imbuf/intern/openexr/openexr_api.cpp
+@@ -45,10 +45,12 @@
+ #include <ImfVersion.h>
+ #include <ImathBox.h>
+ #include <ImfArray.h>
++#include <ImfFrameBuffer.h>
+ #include <ImfIO.h>
+ #include <ImfChannelList.h>
+ #include <ImfPixelType.h>
+ #include <ImfInputFile.h>
++#include <ImfInt64.h>
+ #include <ImfOutputFile.h>
+ #include <ImfCompression.h>
+ #include <ImfCompressionAttribute.h>
+diff --git a/source/blender/alembic/intern/abc_transform.cc b/source/blender/alembic/intern/abc_transform.cc
+index 5392387663f..9dc3200e723 100644
+--- a/source/blender/alembic/intern/abc_transform.cc
++++ b/source/blender/alembic/intern/abc_transform.cc
+@@ -22,7 +22,7 @@
+
+ #include "abc_transform.h"
+
+-#include <OpenEXR/ImathBoxAlgo.h>
++#include <Imath/ImathBoxAlgo.h>
+
+ #include "abc_util.h"
+