summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Epaneshnikov2021-07-13 23:15:40 +0300
committerAlexander Epaneshnikov2021-07-13 23:15:40 +0300
commit24b8724eaec616b96224e80382d1303b0c071523 (patch)
treebe2ede1c4c5226ecea922a0d8092f917baa9ae60
parentd5155d310e45961b0c11ccded77fbdd9322d4c7a (diff)
downloadaur-24b8724eaec616b96224e80382d1303b0c071523.tar.gz
upgpkg: magic-wormhole-git 0.12.0.r19.679434a-1
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD56
-rw-r--r--magic-wormhole-git.patch12
4 files changed, 50 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3468b50ea0f..e76ed16c0b6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = magic-wormhole-git
- pkgdesc = Securely transfer data between computers
- pkgver = 0.11.2.r82.995d3f5
- pkgrel = 3
- url = https://github.com/warner/magic-wormhole
+ pkgdesc = Securely transfer data between computers (development version)
+ pkgver = 0.12.0.r19.679434a
+ pkgrel = 1
+ url = https://github.com/magic-wormhole/magic-wormhole
arch = any
license = MIT
+ checkdepends = python-mock
+ checkdepends = python-magic-wormhole-transit-relay
+ checkdepends = python-magic-wormhole-mailbox-server
makedepends = python-setuptools
- depends = python
+ makedepends = git
depends = python-click
depends = python-cffi
depends = python-autobahn
@@ -18,15 +21,19 @@ pkgbase = magic-wormhole-git
depends = python-idna
depends = python-service-identity
depends = python-txtorcon
- depends = python-pyhamcrest
+ depends = python-pyopenssl
+ provides = magic-wormhole
provides = wormhole
provides = wormhole-server
+ provides = python-wormhole
+ conflicts = magic-wormhole
conflicts = wormhole
conflicts = wormhole-server
- source = git+https://github.com/warner/magic-wormhole.git
- source = magic-wormhole-git.patch
+ conflicts = python-wormhole
+ replaces = wormhole
+ replaces = wormhole-server
+ replaces = python-wormhole
+ source = magic-wormhole::git+https://github.com/magic-wormhole/magic-wormhole.git
sha512sums = SKIP
- sha512sums = b93a25d041c6cded94eed8951d448bf84373516e49498289275e080cba487ea6905128b83c1f7ccb635f1f8045bcdefa0bce6ef9d493060c85b177d65011bbf2
pkgname = magic-wormhole-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..662bff7bb5d3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+magic-wormhole/
diff --git a/PKGBUILD b/PKGBUILD
index b041fb323c0f..a26c18cc1b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,45 @@
-# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+# Maintainer: Alexander Epaneshnikov <aarnaarn2@gmail.com>
pkgname=magic-wormhole-git
-_pkgname=${pkgname%-*}
-pkgver=0.11.2.r82.995d3f5
-pkgrel=3
-pkgdesc="Securely transfer data between computers"
+pkgver=0.12.0.r19.679434a
+pkgrel=1
+pkgdesc='Securely transfer data between computers (development version)'
arch=('any')
-url="https://github.com/warner/${_pkgname}"
+url='https://github.com/magic-wormhole/magic-wormhole'
license=('MIT')
-depends=('python' 'python-click' 'python-cffi' 'python-autobahn' 'python-tqdm' 'python-hkdf' 'python-pynacl' 'python-spake2' 'python-humanize' 'python-idna' 'python-service-identity' 'python-txtorcon' 'python-pyhamcrest')
-makedepends=('python-setuptools')
-source=("git+${url}.git" "magic-wormhole-git.patch")
-conflicts=("wormhole" "wormhole-server")
-provides=("wormhole" "wormhole-server")
-sha512sums=('SKIP'
- 'b93a25d041c6cded94eed8951d448bf84373516e49498289275e080cba487ea6905128b83c1f7ccb635f1f8045bcdefa0bce6ef9d493060c85b177d65011bbf2')
+depends=('python-click' 'python-cffi' 'python-autobahn' 'python-tqdm'
+ 'python-hkdf' 'python-pynacl' 'python-spake2' 'python-humanize'
+ 'python-idna' 'python-service-identity' 'python-txtorcon'
+ 'python-pyopenssl')
+makedepends=('python-setuptools' 'git')
+checkdepends=('python-mock' 'python-magic-wormhole-transit-relay'
+ 'python-magic-wormhole-mailbox-server')
+provides=('magic-wormhole' 'wormhole' 'wormhole-server' 'python-wormhole')
+conflicts=('magic-wormhole' 'wormhole' 'wormhole-server' 'python-wormhole')
+replaces=('wormhole' 'wormhole-server' 'python-wormhole')
+source=(${pkgname%-git}::'git+https://github.com/magic-wormhole/magic-wormhole.git')
+sha512sums=('SKIP')
-pkgver()
-{
- cd "${srcdir}/${_pkgname}"
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
-prepare() {
- patch < "magic-wormhole-git.patch" "$srcdir/$_pkgname/setup.py"
+build() {
+ cd "${pkgname%-git}"
+ python setup.py build
}
-build() {
- cd "${srcdir}/${_pkgname}"
- python setup.py build
+check() {
+ cd "${pkgname%-git}"
+ python setup.py test
}
package() {
- cd "${srcdir}/${_pkgname}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ cd "${pkgname%-git}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -vDm 644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ install -vDm 644 docs/*.md -t "${pkgdir}/usr/share/docs/${pkgname}"
+ install -vDm 644 docs/wormhole.1 -t "${pkgdir}/usr/share/man/man1"
}
diff --git a/magic-wormhole-git.patch b/magic-wormhole-git.patch
deleted file mode 100644
index 8716255bad4b..000000000000
--- a/magic-wormhole-git.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 51b97c3..c64074a 100644
---- a/setup.py
-+++ b/setup.py
-@@ -27,6 +27,7 @@ setup(name="magic-wormhole",
-
- package_dir={"": "src"},
- packages=["wormhole",
-+ "wormhole._dilation",
- "wormhole.cli",
- "wormhole.test",
- ],