summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2018-08-13 15:18:12 +0300
committerAdrian Perez de Castro2018-08-13 15:18:12 +0300
commit24b89482aeff8a8c65b29e6b525877ef57389a59 (patch)
tree1ac878f58392f0e16e8982ab20db63857c4f858b
downloadaur-24b89482aeff8a8c65b29e6b525877ef57389a59.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e762a331f3ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fuse-ext2
+ pkgdesc = A multi OS FUSE module to mount ext2, ext3 and ext4 file system devices and/or images with read write support
+ pkgver = 0.0.10
+ pkgrel = 1
+ url = https://github.com/alperakcan/fuse-ext2
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ depends = fuse2
+ depends = e2fsprogs
+ conflicts = fuse-ext2-git
+ source = https://github.com/alperakcan/fuse-ext2/archive/v0.0.10.tar.gz
+ sha512sums = b884c0f92b706ae3f03dd75f489990e7cea31fd68526ade48ab5a11e1c9f78ec02a4dbb82450ce2aca12742a799c334a3ab8f2443a96ad003a76f0a86567fa24
+
+pkgname = fuse-ext2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..031407c58e92
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar
+/*.tar.*
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9e0ed72878b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
+pkgname=fuse-ext2
+pkgver=0.0.10
+pkgrel=1
+pkgdesc='A multi OS FUSE module to mount ext2, ext3 and ext4 file system devices and/or images with read write support'
+url='https://github.com/alperakcan/fuse-ext2'
+license=('GPL2')
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+depends=('fuse2' 'e2fsprogs')
+conflicts=("${pkgname}-git")
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha512sums=('b884c0f92b706ae3f03dd75f489990e7cea31fd68526ade48ab5a11e1c9f78ec02a4dbb82450ce2aca12742a799c334a3ab8f2443a96ad003a76f0a86567fa24')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ autoreconf --install --symlink
+ CPPFLAGS='-include /usr/include/sys/sysmacros.h' ./configure --prefix=/usr --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}