summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-09-16 09:51:27 +0200
committertytan6522022-09-16 09:51:27 +0200
commit24e2c90886470655000701d7df2854ef02a5d95a (patch)
tree0252dc37e623a52eabca4f0719e9f70487348ca0
parent928de04dd212f99f77a2c2de6b1eb896b9917e6a (diff)
downloadaur-24e2c90886470655000701d7df2854ef02a5d95a.tar.gz
build: Update to version 1.6.11
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD60
2 files changed, 16 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db1e9223fe8d..50724e652131 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-replay-source
pkgdesc = Plugin to (slow motion) instant replay sources from memory
- pkgver = 1.6.10
+ pkgver = 1.6.11
pkgrel = 1
url = https://obsproject.com/forum/resources/replay-source.686/
arch = i686
@@ -9,13 +9,9 @@ pkgbase = obs-replay-source
license = GPL2
makedepends = cmake
makedepends = git
- makedepends = libxcomposite
- makedepends = ffmpeg
- makedepends = pciutils
- depends = obs-studio>=27.2.0
- source = obs-replay-source::git+https://github.com/exeldro/obs-replay-source#commit=319f0806784a98ca813c4ba7f0e1b3c19d0d149e
- source = obs-studio-27.2.0.tar.gz::https://github.com/obsproject/obs-studio/archive/27.2.0.tar.gz
+ makedepends = libcaption
+ depends = obs-studio>=28
+ source = obs-replay-source::git+https://github.com/exeldro/obs-replay-source#commit=5c3866fcd3ae3834c75715e52239d531d445fd65
sha256sums = SKIP
- sha256sums = c52d99cba6c536cb805e3e0f54663c33cfc43a1b7521bec97d241019499f9789
pkgname = obs-replay-source
diff --git a/PKGBUILD b/PKGBUILD
index 6374ea3a62b5..62117a1177b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,30 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
-_pluginname=replay-source
-pkgname=obs-$_pluginname
-pkgver=1.6.10
-_obsver=27.2.0
+pkgname=obs-replay-source
+pkgver=1.6.11
pkgrel=1
pkgdesc="Plugin to (slow motion) instant replay sources from memory"
arch=("i686" "x86_64" "aarch64")
url="https://obsproject.com/forum/resources/replay-source.686/"
license=("GPL2")
-depends=("obs-studio>=$_obsver")
-makedepends=("cmake" "git" "libxcomposite" "ffmpeg" "pciutils")
-source=(
- "$pkgname::git+https://github.com/exeldro/$pkgname#commit=319f0806784a98ca813c4ba7f0e1b3c19d0d149e"
- "obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
-)
-sha256sums=(
- "SKIP"
- "c52d99cba6c536cb805e3e0f54663c33cfc43a1b7521bec97d241019499f9789"
-)
-
-prepare() {
- rm -rf fakeroot
-
- cd "obs-studio-$_obsver"/plugins
- cp -r "$srcdir/$pkgname" .
- echo "add_subdirectory($pkgname)" | tee -a CMakeLists.txt >/dev/null
-}
+depends=("obs-studio>=28")
+makedepends=("cmake" "git" "libcaption")
+source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=5c3866fcd3ae3834c75715e52239d531d445fd65")
+sha256sums=("SKIP")
# Need to compile plugin in OBS compilation process
build() {
- cd "obs-studio-$_obsver"
+ cd "$pkgname"
cmake -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DDISABLE_UI=ON \
- -DENABLE_WAYLAND=OFF \
- -DENABLE_PIPEWIRE=OFF \
- -DENABLE_SCRIPTING=OFF \
- -DDISABLE_DECKLINK=ON \
- -DDISABLE_ALSA=ON \
- -DDISABLE_JACK=ON \
- -DDISABLE_PULSEAUDIO=ON \
- -DDISABLE_V4L2=ON \
- -DDISABLE_SPEEXDSP=ON \
- -DDISABLE_LIBFDK=ON \
- -DDISABLE_SNDIO=ON \
- -DDISABLE_FREETYPE=ON \
- -DDISABLE_VLC=ON \
- -DBUILD_BROWSER=OFF \
- -DBUILD_VST=OFF \
- -DWITH_RTMPS=OFF
+ -DLINUX_PORTABLE=OFF
make -C build
}
package() {
- mkdir -p "$pkgdir"/usr/lib/obs-plugins
- mkdir -p "$pkgdir"/usr/share/obs/obs-plugins
-
- cd "obs-studio-$_obsver"
- make -C build DESTDIR="$srcdir/fakeroot/" install
- cp -a "$srcdir"/fakeroot/usr/lib/obs-plugins/$_pluginname.so "$pkgdir"/usr/lib/obs-plugins/
- cp -a "$srcdir"/fakeroot/usr/share/obs/obs-plugins/$_pluginname "$pkgdir"/usr/share/obs/obs-plugins/
+ cd "$pkgname"
+ make -C build DESTDIR="$pkgdir/" install
} \ No newline at end of file