summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortomsik682016-02-02 11:02:25 +0000
committertomsik682016-02-02 11:02:25 +0000
commit253413c9c7ad29dba139b845cb013dd6ec66614d (patch)
treeb5a868f114e22ff6609debd8b0ed5484ee00e292
parent28989f98a93ec813d348196be3b901560dafdd0a (diff)
downloadaur-253413c9c7ad29dba139b845cb013dd6ec66614d.tar.gz
Added .desktop file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--aptana-studio.desktop9
3 files changed, 18 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97d4b37275e9..603ae35af07d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = aptana-studio
pkgdesc = Aptana Studio 3.6.1 is code base and complete eclipse-based environment that includes extensive capabilities to build Ruby and Rails, PHP, and Python applications, along with complete HTML, CSS and JavaScript editing.
pkgver = 3.6.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.aptana.com/products/studio3/download.html
arch = i686
arch = x86_64
license = GPL3
makedepends = tar
depends = java-runtime
+ source = aptana-studio.desktop
+ md5sums = 6b3b2d4809ac7c92c312950f06224387
source_i686 = https://github.com/aptana/studio3/releases/download/v3.6.1/Aptana_Studio_3_Setup_Linux_x86_3.6.1.zip
md5sums_i686 = bf3c1923ea051c29803b6bc2b5d50ff9
source_x86_64 = https://github.com/aptana/studio3/releases/download/v3.6.1/Aptana_Studio_3_Setup_Linux_x86_64_3.6.1.zip
diff --git a/PKGBUILD b/PKGBUILD
index 53c59b2d8822..a7afba8c3d59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Tomas Jasek <tomsik68(at)gmail(dot)com>
+# Contributor: Aisberg
pkgname="aptana-studio"
pkgver="3.6.1"
-pkgrel=1
+pkgrel=2
pkgdesc="Aptana Studio 3.6.1 is code base and complete eclipse-based environment that includes extensive capabilities to build Ruby and Rails, PHP, and Python applications, along with complete HTML, CSS and JavaScript editing. "
arch=('i686' 'x86_64')
url="http://www.aptana.com/products/studio3/download.html"
@@ -19,9 +20,11 @@ options=()
install=
changelog=
source_i686=("https://github.com/aptana/studio3/releases/download/v3.6.1/Aptana_Studio_3_Setup_Linux_x86_${pkgver}.zip")
-source_x86_64=("https://github.com/aptana/studio3/releases/download/v3.6.1/Aptana_Studio_3_Setup_Linux_x86_64_${pkgver}.zip")
md5sums_i686=('bf3c1923ea051c29803b6bc2b5d50ff9')
+source_x86_64=("https://github.com/aptana/studio3/releases/download/v3.6.1/Aptana_Studio_3_Setup_Linux_x86_64_${pkgver}.zip")
md5sums_x86_64=('5df9fa66cd28648e311c1ca662de1508')
+source=("aptana-studio.desktop")
+md5sums=("6b3b2d4809ac7c92c312950f06224387")
noextract=()
build() {
@@ -40,4 +43,5 @@ package() {
rm -rf Aptana_Studio_3
mkdir -p $pkgdir/usr/bin/
install -m775 $srcdir/usr/bin/aptana-studio $pkgdir/usr/bin/aptana-studio
+ install -Dm644 $srcdir/aptana-studio.desktop "${pkgdir}/usr/share/applications/aptana-studio.desktop"
}
diff --git a/aptana-studio.desktop b/aptana-studio.desktop
new file mode 100644
index 000000000000..1d101a40f3b2
--- /dev/null
+++ b/aptana-studio.desktop
@@ -0,0 +1,9 @@
+ [Desktop Entry]
+ Name=Aptana Studio 3
+ Comment=A web development IDE
+ Icon=/usr/lib/aptana/icon.xpm
+ Exec=aptana-studio
+ Terminal=false
+ Type=Application
+ Categories=Development;IDE;Web;HTML;PHP;CSS;
+ StartupNotify=true