summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlailect2016-02-04 22:49:17 -0500
committerPlailect2016-02-04 22:49:17 -0500
commit2555813bb6cc910a17d8fae39249c6ab1d83164e (patch)
tree25612b5a94cfd4ebe90f0dc8a1d9fd30d9496067
downloadaur-2555813bb6cc910a17d8fae39249c6ab1d83164e.tar.gz
Initial Import
-rw-r--r--.SRCINFO39
-rw-r--r--MKPKG4
-rw-r--r--PKGBUILD65
3 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ad28666c510
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+# Generated by mksrcinfo v8
+# Fri Feb 5 03:48:50 UTC 2016
+pkgbase = dolphin-emu-git-netplay
+ pkgdesc = A GameCube / Wii / Triforce emulator, v4.0-7840 for Super Smash Bros Netplay
+ pkgver = 4.0.2.r7840.ce493b8
+ pkgrel = 1
+ url = http://www.dolphin-emu.org/
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = qt5-base
+ depends = bluez-libs
+ depends = enet
+ depends = ffmpeg
+ depends = libao
+ depends = libevdev
+ depends = mbedtls
+ depends = miniupnpc
+ depends = portaudio
+ depends = sfml
+ depends = soundtouch
+ depends = xdg-utils
+ depends = wxgtk
+ optdepends = pulseaudio: PulseAudio backend
+ options = !emptydirs
+ source = dolphin-emu::git+https://github.com/dolphin-emu/dolphin.git#commit=ce493b8
+ sha256sums = SKIP
+
+pkgname = dolphin-emu-git-netplay
+ provides = dolphin-emu
+ conflicts = dolphin-emu
+ conflicts = dolphin-emu-git
+
+pkgname = dolphin-emu-cli-git-netplay
+ depends = dolphin-emu-git-netplay
+
+pkgname = dolphin-emu-qt-git-netplay
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..64c4b1b3ae81
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,4 @@
+arch=('x86_64')
+pkgname=('dolphin-emu-git-netplay' 'dolphin-emu-cli-git-netplay')
+
+check_git $packagedir/dolphin-emu-git/dolphin-emu
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..505c70738177
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Plailect <plailect@gmail.com>
+# Dolphin-Emu-Git Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Lightning <sgsdxzy@gmail.com>
+
+pkgbase=dolphin-emu-git-netplay
+pkgname=('dolphin-emu-git-netplay' 'dolphin-emu-cli-git-netplay' 'dolphin-emu-qt-git-netplay')
+pkgver=4.0.2.r7840.ce493b8
+pkgrel=1
+pkgdesc='A GameCube / Wii / Triforce emulator, v4.0-7840 for Super Smash Bros Netplay'
+arch=('x86_64')
+url='http://www.dolphin-emu.org/'
+license=('GPL2')
+depends=('bluez-libs' 'enet' 'ffmpeg' 'libao' 'libevdev' 'mbedtls' 'miniupnpc'
+ 'portaudio' 'sfml' 'soundtouch' 'xdg-utils' 'wxgtk')
+makedepends=('cmake' 'git' 'qt5-base')
+optdepends=('pulseaudio: PulseAudio backend')
+options=('!emptydirs')
+source=('dolphin-emu::git+https://github.com/dolphin-emu/dolphin.git#commit=ce493b8')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd dolphin-emu
+
+ echo "4.0.2.r$(git rev-list --count 4.0..HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ sed -i -e 's/2000, nullptr, nullptr, 0, 0/2000, nullptr, nullptr, 0, 0, 2/g' dolphin-emu/Source/Core/Core/NetPlayServer.cpp
+
+ cd dolphin-emu
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_C_FLAGS='-fno-pie' \
+ -DCMAKE_CXX_FLAGS='-fno-pie' \
+ -DENABLE_LTO='TRUE' \
+ -DENABLE_QT2='TRUE' \
+ -DENABLE_SDL='TRUE' \
+ -DUSE_SHARED_ENET='TRUE'
+ make
+}
+
+package_dolphin-emu-git-netplay() {
+ provides=('dolphin-emu')
+ conflicts=('dolphin-emu' 'dolphin-emu-git')
+
+ cd dolphin-emu/build
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/bin/dolphin-emu-{nogui,qt2}
+}
+
+package_dolphin-emu-cli-git-netplay() {
+ depends=('dolphin-emu-git-netplay')
+
+ cd dolphin-emu/build
+
+ install -dm 755 "${pkgdir}"/usr/bin
+ install -m 755 Binaries/dolphin-emu-nogui "${pkgdir}"/usr/bin/dolphin-emu-cli
+}