summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Hague2015-10-21 23:14:45 +0100
committerMatthew Hague2015-10-21 23:14:45 +0100
commit256f78d20191f9ff941f0b89543f872cb48f99af (patch)
tree32708932af8b141748541c8c7c59381147bfc5f7
downloadaur-256f78d20191f9ff941f0b89543f872cb48f99af.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..164d8689dc79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-extract-url-git
+ pkgdesc = Alternative or preprocessor for urlview, primarily for use with mutt
+ pkgver = 1
+ pkgrel = 1
+ url = http://www.memoryhole.net/~kyle/extract_url
+ arch = any
+ license = BSD-2-Clause (simplified)
+ depends = perl
+ depends = perl-mime-tools
+ depends = perl-html-parser
+ optdepends = perl-curses-ui: allows it to fully replace urlview
+ replaces = extracturl-git
+ source = git://github.com/m3m0ryh0l3/extracturl.git
+ sha256sums = SKIP
+
+pkgname = perl-extract-url-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f600dbe770e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Matthew Hague <matthewhague at zoho dot com>
+
+pkgname=perl-extract-url-git
+pkgver=1
+pkgrel=1
+pkgdesc='Alternative or preprocessor for urlview, primarily for use with mutt'
+arch=(any)
+url='http://www.memoryhole.net/~kyle/extract_url'
+replaces=(extracturl-git)
+conflicts=(extracturl-git)
+license=('BSD-2-Clause (simplified)')
+depends=('perl'
+ 'perl-mime-tools'
+ 'perl-html-parser')
+optdepends=('perl-curses-ui: allows it to fully replace urlview')
+source=(git://github.com/m3m0ryh0l3/extracturl.git)
+sha256sums=('SKIP')
+
+package() {
+ cd $srcdir/extracturl
+ make
+ make DESTDIR=$pkgdir install
+}