summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2019-02-06 15:56:32 +0700
committerKonstantin Shalygin2019-02-06 15:56:32 +0700
commit25c5730fdb1addc80ae06daa8e349a4c6b34e98b (patch)
treed2d89342640c35691a13fd5b3de54a61ce62edf4
downloadaur-25c5730fdb1addc80ae06daa8e349a4c6b34e98b.tar.gz
First release of OpenVPN OTP plugin.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1c777e3b276
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Feb 6 08:55:36 UTC 2019
+pkgbase = openvpn-otp
+ pkgdesc = This plug-in adds support for time based OTP (totp) and HMAC based OTP (hotp) tokens (like Google Authenticator) for OpenVPN.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/evgeny-gridasov/openvpn-otp
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = openvpn
+ depends = openssl
+ source = openvpn-otp::git+https://github.com/evgeny-gridasov/openvpn-otp
+ sha256sums = SKIP
+
+pkgname = openvpn-otp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c88e6f3f37e8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/*
+src/*
+*.tar.*
+openvpn-otp/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7daedd262d33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Shalygin Konstantin <k0ste@k0ste.ru>
+# Contributor: Shalygin Konstantin <k0ste@k0ste.ru>
+
+pkgname='openvpn-otp'
+pkgver='1.0'
+pkgrel='1'
+pkgdesc='This plug-in adds support for time based OTP (totp) and HMAC based OTP (hotp) tokens (like Google Authenticator) for OpenVPN.'
+arch=('any')
+url="https://github.com/evgeny-gridasov/${pkgname}"
+license=('BSD')
+depends=('openvpn' 'openssl')
+source=("${pkgname}::git+${url}")
+makedepends=('git')
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ ./autogen.sh
+ ./configure \
+ --prefix="/usr" \
+ --with-openvpn-plugin-dir="/usr/lib/openvpn/plugins"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}