summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2016-05-08 20:38:19 +0200
committerJohannes Dewender2016-05-08 20:42:35 +0200
commit25de333800746292718dc758b8606cbb177fe16f (patch)
tree92aeb68164cfcbd3cf126cf492a67c688f579845
parent1747c5bb6da5ceebce8b39f69293e9b1c9cfd1b3 (diff)
downloadaur-25de333800746292718dc758b8606cbb177fe16f.tar.gz
2.6.0 including Python 3 support
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 26 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb16dc0324c6..cfdc420d7063 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun May 8 18:42:35 UTC 2016
pkgbase = python2-debianbts
pkgdesc = Python interface to Debians Bug Tracking System
- pkgver = 1.12
+ pkgver = 2.6.0
pkgrel = 1
url = http://packages.debian.org/sid/python-debianbts
arch = any
license = GPL2
- depends = python2-soappy
- depends = python2-support
+ makedepends = python-pysimplesoap
+ makedepends = python2-pysimplesoap
options = !emptydirs
- source = http://ftp.debian.org/debian/pool/main/p/python-debianbts/python-debianbts_1.12.tar.xz
- sha256sums = 1b3e6b8a9618e63bb9f6f945230588cdcb273fb1fcb959c9811d435e1b0e896f
+ source = http://ftp.debian.org/debian/pool/main/p/python-debianbts/python-debianbts_2.6.0.tar.xz
+ sha256sums = 61781b5aa708c27b0bbbec5a72ff71c6770a453ce64ffae9d23c815031956231
pkgname = python2-debianbts
+ depends = python2-pysimplesoap
+
+pkgname = python-debianbts
+ depends = python-pysimplesoap
diff --git a/PKGBUILD b/PKGBUILD
index 8e3890c39468..fd429c4f0070 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,32 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
-pkgname=python2-debianbts
+pkgname=('python2-debianbts' 'python-debianbts')
_pkgname=python-debianbts
-_python=python2
-pkgver=1.12
+pkgver=2.6.0
pkgrel=1
pkgdesc="Python interface to Debians Bug Tracking System"
arch=('any')
url="http://packages.debian.org/sid/python-debianbts"
license=('GPL2')
-depends=('python2-soappy' 'python2-support')
-makedepends=()
-conflicts=()
+makedepends=('python-pysimplesoap' 'python2-pysimplesoap')
options=(!emptydirs)
source=(http://ftp.debian.org/debian/pool/main/p/$_pkgname/${_pkgname}_$pkgver.tar.xz)
-sha256sums=('1b3e6b8a9618e63bb9f6f945230588cdcb273fb1fcb959c9811d435e1b0e896f')
+sha256sums=('61781b5aa708c27b0bbbec5a72ff71c6770a453ce64ffae9d23c815031956231')
build() {
cd "$srcdir/$_pkgname-$pkgver"
- $_python setup.py build
+ python setup.py build
}
-package() {
+
+package_python-debianbts() {
+ depends=('python-pysimplesoap')
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-debianbts() {
+ depends=('python2-pysimplesoap')
cd "$srcdir/$_pkgname-$pkgver"
- $_python setup.py install --root="$pkgdir/" --optimize=1
+ python2 setup.py install --root="$pkgdir/" --optimize=1
}
# vim:set ts=2 sw=2 et: