summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2020-12-09 11:26:21 +0100
committerFrank Siegert2020-12-09 11:26:21 +0100
commit25f303eca0b421b187a2997fab23c8b96e2ce6ce (patch)
tree1b7bed7291dad9070d5a7bf1966d68f1bbc3448d
parentaa52e94668641ff22df0b849fe78201420991ad3 (diff)
downloadaur-25f303eca0b421b187a2997fab23c8b96e2ce6ce.tar.gz
Update to 3.1.3-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb7480a0d65f..bfb71509ab75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rivet
pkgdesc = A particle physics package for data analysis and validation of Monte Carlo event generators
- pkgver = 3.1.2
- pkgrel = 2
+ pkgver = 3.1.3
+ pkgrel = 1
url = http://rivet.hepforge.org
arch = x86_64
arch = i686
@@ -17,8 +17,12 @@ pkgbase = rivet
optdepends = ghostscript: PDF plot output
optdepends = imagemagick: PNG plot output
optdepends = python2: For Python2 module in addition to Python3
- source = http://www.hepforge.org/archive/rivet/Rivet-3.1.2.tar.gz
- md5sums = 856079204e36e1c5e4077cf509c8490f
+ source = http://www.hepforge.org/archive/rivet/Rivet-3.1.3.tar.gz
+ source = https://gitlab.com/hepcedar/rivet/-/commit/3203bf12a4bef81f880789eb9cde7ff489ae5115.diff
+ source = https://gitlab.com/hepcedar/rivet/-/commit/476f267c46b126fa163a92aa6cbcb7806c4624c3.diff
+ md5sums = 4738ae56037ce7edfedc2fe59432563c
+ md5sums = f38fb653e6927c0a3103abe7015f4372
+ md5sums = 4873c74c63650765c2d5270197978e05
pkgname = rivet
diff --git a/PKGBUILD b/PKGBUILD
index 685e364975a1..1b3669550bce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
pkgname=rivet
-pkgver=3.1.2
-pkgrel=2
+pkgver=3.1.3
+pkgrel=1
pkgdesc="A particle physics package for data analysis and validation of Monte Carlo event generators"
arch=('x86_64' 'i686')
url="http://rivet.hepforge.org"
@@ -12,12 +12,20 @@ optdepends=('texlive-core: Plotting functionality'
'imagemagick: PNG plot output'
'python2: For Python2 module in addition to Python3')
makedepends=('cython')
-source=(http://www.hepforge.org/archive/rivet/Rivet-$pkgver.tar.gz)
-md5sums=('856079204e36e1c5e4077cf509c8490f')
+source=(http://www.hepforge.org/archive/rivet/Rivet-$pkgver.tar.gz
+ https://gitlab.com/hepcedar/rivet/-/commit/3203bf12a4bef81f880789eb9cde7ff489ae5115.diff
+ https://gitlab.com/hepcedar/rivet/-/commit/476f267c46b126fa163a92aa6cbcb7806c4624c3.diff
+ )
+md5sums=('4738ae56037ce7edfedc2fe59432563c'
+ 'f38fb653e6927c0a3103abe7015f4372'
+ '4873c74c63650765c2d5270197978e05')
package() {
cd "$srcdir/Rivet-$pkgver"
+ patch -p1 < ../3203bf12a4bef81f880789eb9cde7ff489ae5115.diff
+ patch -p1 < ../476f267c46b126fa163a92aa6cbcb7806c4624c3.diff
+
# If python2 is present, also build a library for it
# Have to do this first, such that files like rivet-config get overwritten with the "proper" Python3 version
if [ -x /usr/bin/python2 ]; then