summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkbipinkumar2022-12-01 10:46:51 +0530
committerkbipinkumar2022-12-01 10:46:51 +0530
commit2607504127f6658cc65d2b3e0b77df09bc74dbad (patch)
tree87964e6e9bb1ef83c4c3226aa36310e0b5f726f7
parent6e2e5282cf1496038a21035e1affde8c5f56ab8b (diff)
downloadaur-2607504127f6658cc65d2b3e0b77df09bc74dbad.tar.gz
version update to 5.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04a778d91cc2..a9ad896ce817 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = snpeff
- pkgdesc = Genetic variant annotation and effect prediction toolbox
- pkgver = 4_3t
- pkgrel = 2
- url = http://snpeff.sourceforge.net/
+ pkgdesc = Genetic variant annotation and effect prediction toolbox. https://doi.org/10.4161/fly.19695
+ pkgver = 5.1
+ pkgrel = 1
+ url = https://pcingola.github.io/SnpEff/
arch = any
- license = (L)GPL3
- depends = java-runtime>=8
+ license = MIT
+ depends = java-runtime>=12
source = snpEff.sh
source = SnpSift.sh
- source = http://sourceforge.net/projects/snpeff/files/snpEff_v4_3t_core.zip
+ source = https://snpeff.blob.core.windows.net/versions/snpEff_latest_core.zip
sha256sums = e0ba5679a90efdb39cd9398b1db708444fd8e5321182cedf72696b3ae1e2e2b9
sha256sums = 4bd0163c6b8864ed6ea3f20d215b0bf371e10eaa4156ffcf8429d6f71ded93e3
- sha256sums = d55a7389a78312947c1e7dadf5e6897b42d3c6e942e7c1b8ec68bb35d2ae2244
+ sha256sums = 919e0595c08e86d1dd82279723c83cb872070244ee4ce0cb3167bde2b272893b
pkgname = snpeff
-
diff --git a/PKGBUILD b/PKGBUILD
index fd15d348f699..c5c12a062106 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,33 @@
# Maintainer: Clint Valentine <valentine.clint@gmail.com>
pkgname=snpeff
-pkgver=4_3t
-pkgrel=2
-pkgdesc="Genetic variant annotation and effect prediction toolbox"
+pkgver=5.1
+pkgrel=1
+pkgdesc="Genetic variant annotation and effect prediction toolbox. https://doi.org/10.4161/fly.19695"
arch=('any')
-url="http://snpeff.sourceforge.net/"
-license=('(L)GPL3')
-depends=('java-runtime>=8')
+url="https://pcingola.github.io/SnpEff/"
+license=('MIT')
+depends=('java-runtime>=12')
source=(
snpEff.sh
SnpSift.sh
- http://sourceforge.net/projects/"${pkgname}"/files/snpEff_v"${pkgver}"_core.zip
-)
-sha256sums=(
- 'e0ba5679a90efdb39cd9398b1db708444fd8e5321182cedf72696b3ae1e2e2b9'
- '4bd0163c6b8864ed6ea3f20d215b0bf371e10eaa4156ffcf8429d6f71ded93e3'
- 'd55a7389a78312947c1e7dadf5e6897b42d3c6e942e7c1b8ec68bb35d2ae2244'
+ https://snpeff.blob.core.windows.net/versions/snpEff_latest_core.zip
+ #http://sourceforge.net/projects/"${pkgname}"/files/snpEff_v"${pkgver}"_core.zip
)
+sha256sums=('e0ba5679a90efdb39cd9398b1db708444fd8e5321182cedf72696b3ae1e2e2b9'
+ '4bd0163c6b8864ed6ea3f20d215b0bf371e10eaa4156ffcf8429d6f71ded93e3'
+ '919e0595c08e86d1dd82279723c83cb872070244ee4ce0cb3167bde2b272893b')
package() {
cd "${srcdir}/"
-
+ install -Dm644 snpEff/snpEff.jar "${pkgdir}"/usr/share/java/snpEff/snpEff.jar
+ for d in snpEff/ ; do
+ cp -R "$d" "${pkgdir}"/usr/share/java/
+ done
install -Dm644 snpEff/snpEff.jar "${pkgdir}"/usr/share/java/snpEff/snpEff.jar
install -Dm644 snpEff/SnpSift.jar "${pkgdir}"/usr/share/java/snpEff/SnpSift.jar
install -Dm644 snpEff/snpEff.config "${pkgdir}"/usr/share/java/snpEff/snpEff.config
+ install -Dm644 snpEff/LICENSE.md "${pkgdir}"/usr/share/licenses/snpEff/LICENSE.md
install -Dm755 snpEff.sh "${pkgdir}"/usr/bin/snpEff
install -Dm755 SnpSift.sh "${pkgdir}"/usr/bin/SnpSift
}