summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2021-12-12 08:38:14 -0300
committerGonzalo Exequiel Pedone2021-12-12 08:38:14 -0300
commit260c05dee0c42dfe676cc43b0119e24fbe07e4ce (patch)
treebf48ac644963aab5edacae1e98b0726b5beff2b9
parentaac6d3a3c59f712d874e6e4456a234cd3448ed94 (diff)
downloadaur-260c05dee0c42dfe676cc43b0119e24fbe07e4ce.tar.gz
Fixed missing headers.
-rw-r--r--.SRCINFO7
-rw-r--r--0001-Fix-missing-headers.patch10
-rw-r--r--PKGBUILD13
3 files changed, 24 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8b4c074090e..434bbca2017d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = webcamoid
pkgdesc = Webcamoid is a full featured webcam capture application.
pkgver = 8.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://webcamoid.github.io/
install = webcamoid.install
arch = i686
@@ -40,7 +40,8 @@ pkgbase = webcamoid
provides = webcamoid
conflicts = webcamoid-git
source = webcamoid-8.8.0.tar.gz::https://github.com/webcamoid/webcamoid/archive/8.8.0.tar.gz
- sha256sums = 77ed77cbaf57180247485646b81af30edcc89ee545bc241c23d8bd648464bf15
+ source = 0001-Fix-missing-headers.patch
+ md5sums = d2b4455aa01924a07fc03165185e317c
+ md5sums = f7a79dac3b251f0e0454e512222e3306
pkgname = webcamoid
-
diff --git a/0001-Fix-missing-headers.patch b/0001-Fix-missing-headers.patch
new file mode 100644
index 000000000000..cf4e68aacd7d
--- /dev/null
+++ b/0001-Fix-missing-headers.patch
@@ -0,0 +1,10 @@
+--- a/libAvKys/Plugins/VirtualCamera/src/VCamUtils/src/image/videoformat.cpp 2021-02-15 12:25:23.000000000 -0300
++++ b/libAvKys/Plugins/VirtualCamera/src/VCamUtils/src/image/videoformat.cpp 2021-12-12 08:15:03.519178427 -0300
+@@ -17,6 +17,7 @@
+ * Web-Site: http://webcamoid.github.io/
+ */
+
++#include <limits>
+ #include <map>
+ #include <algorithm>
+
diff --git a/PKGBUILD b/PKGBUILD
index 6943c88a73f8..adecd356f89c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=webcamoid
pkgver=8.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Webcamoid is a full featured webcam capture application."
url='https://webcamoid.github.io/'
license=('GPL')
@@ -39,8 +39,15 @@ makedepends=('v4l-utils'
provides=('webcamoid')
conflicts=('webcamoid-git')
install="${pkgname}.install"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('77ed77cbaf57180247485646b81af30edcc89ee545bc241c23d8bd648464bf15')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz"
+ "0001-Fix-missing-headers.patch")
+md5sums=('d2b4455aa01924a07fc03165185e317c'
+ 'f7a79dac3b251f0e0454e512222e3306')
+
+prepare() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ patch -Np1 -i "../0001-Fix-missing-headers.patch"
+}
build() {
cd "$srcdir/${pkgname}-${pkgver}"