summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Harvey2016-07-14 21:15:08 -0400
committerJames Harvey2016-07-14 21:15:08 -0400
commit260e840e93053d363b70190f83bd589f9b4e80dd (patch)
tree7ea13e190ef22a54b01966a4dd8a4e3e2ff80052
downloadaur-260e840e93053d363b70190f83bd589f9b4e80dd.tar.gz
Initial import, a fork of AUR opensm, only changes are to PKGBUILD to represent the forking
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD50
-rw-r--r--opensm.launch9
-rw-r--r--opensm.service19
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e69ab8a24891
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Fri Jul 15 01:14:00 UTC 2016
+pkgbase = opensm-systemd-multiple-interfaces
+ pkgdesc = OpenFabrics Alliance InfiniBand Subnet Manager and Administrator
+ pkgver = 3.3.20
+ pkgrel = 1
+ url = https://www.openfabrics.org/index.php/overview.html
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ license = custom:"Open Fabrics Alliance BSD"
+ depends = libibumad
+ depends = rdma
+ provides = opensm
+ conflicts = opensm
+ source = https://www.openfabrics.org/downloads/management/opensm-3.3.20.tar.gz
+ source = opensm.service
+ source = opensm.launch
+ md5sums = ed615b4681e94ef2e13a5de773ab89a3
+ md5sums = f1155dd8fb07ce56c427bceb7ce3fffb
+ md5sums = 7cd151f96d46ba1bc651fce0e2b7e8dc
+
+pkgname = opensm-systemd-multiple-interfaces
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5049baf66d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: James Harvey <jamespharvey20@gmail.com>
+# * OpenFabrics Alliance InfiniBand subnet manager (SM) and subnet administrator (SA)
+# * One subnet manager is required to run each InfiniBand subnet, before initializing InfiniBand hardware
+# * No Namcap warnings or errors
+# Up to date with fedora's opensm-3.3.17-5.fc23.src.rpm
+
+pkgname=opensm-systemd-multiple-interfaces
+_pkgbase=opensm
+pkgver=3.3.20
+pkgrel=1
+pkgdesc='OpenFabrics Alliance InfiniBand Subnet Manager and Administrator'
+arch=('x86_64' 'i686')
+url='https://www.openfabrics.org/index.php/overview.html'
+license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
+provides=('opensm')
+conflicts=('opensm')
+depends=('libibumad' 'rdma')
+source=("https://www.openfabrics.org/downloads/management/${_pkgbase}-${pkgver}.tar.gz"
+ 'opensm.service'
+ 'opensm.launch')
+md5sums=('ed615b4681e94ef2e13a5de773ab89a3'
+ 'f1155dd8fb07ce56c427bceb7ce3fffb'
+ '7cd151f96d46ba1bc651fce0e2b7e8dc')
+
+build() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+
+ # Convert from init.d to systemd
+ rm -rf ${pkgdir}/etc/init.d
+ # If ${pkgdir}/etc is empty (it should be, since /etc/init.d/ was removed) remove it
+ if ! [ "$(ls -A ${pkgdir}/etc)" ]; then
+ rm -rf ${pkgdir}/etc/
+ fi
+
+ install -Dm644 "${srcdir}/opensm.service" "${pkgdir}/usr/lib/systemd/system/opensm.service"
+ install -Dm755 "${srcdir}/opensm.launch" "${pkgdir}/usr/bin/opensm.launch"
+}
diff --git a/opensm.launch b/opensm.launch
new file mode 100644
index 000000000000..08f0b1f5ec2f
--- /dev/null
+++ b/opensm.launch
@@ -0,0 +1,9 @@
+#!/bin/bash
+# Copied from Fedora's opensm-3.3.17-4.fc22.x86_64.rpm
+# Modified to just launch opensm
+# Will come back to adding multiple OpenSM daemons running at once, which is what the rest of Fedora's version is for
+#
+# Launch the necessary OpenSM daemons for systemd
+
+(while true; do /usr/bin/opensm; sleep 30; done) &
+exit 0
diff --git a/opensm.service b/opensm.service
new file mode 100644
index 000000000000..edf2b9551273
--- /dev/null
+++ b/opensm.service
@@ -0,0 +1,19 @@
+# Copied from Fedora's opensm-3.3.17-4.fc22.x86_64.rpm
+# Modified to follow Arch layout
+
+[Unit]
+Description=Starts the OpenSM InfiniBand fabric Subnet Manager
+Documentation=man:opensm
+DefaultDependencies=false
+Before=network.target remote-fs-pre.target
+Requires=rdma.service
+After=rdma.service
+
+[Service]
+Type=forking
+# There is a timing bug that intermittently causes signal 15 failures on start
+# Fedora's workaround is to use a separate script
+ExecStart=/usr/bin/opensm.launch
+
+[Install]
+WantedBy=network.target