summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortomsik682015-06-09 12:12:29 +0200
committertomsik682015-06-09 12:12:56 +0200
commit261a8ebce76d7126978d9affaf12b8610216afbe (patch)
tree5a65aac64c8d71dfa1fb1783b4de8559aea2e70a
downloadaur-261a8ebce76d7126978d9affaf12b8610216afbe.tar.gz
Import from AUR3
-rw-r--r--.SRCINFO24
-rw-r--r--INSTALL-path.patch8
-rw-r--r--PKGBUILD41
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6d7f0293aeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = sdl2-vapi-git
+ pkgdesc = SDL2 Bindings for vala language
+ pkgver = b8ce044
+ pkgrel = 3
+ url = https://github.com/desiderantes/sdl2_vapi
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vala
+ depends = sdl2
+ optdepends = sdl2_gfx: SDL Graphic Primitives
+ optdepends = sdl2_image: A simple library to load images of various formats as SDL surfaces
+ optdepends = sdl2_mixer: A simple multi-channel audio mixer
+ optdepends = sdl2_net: A small sample cross-platform networking library
+ optdepends = sdl2_ttf: A library that allows you to use TrueType fonts in your SDL applications
+ provides = sdl2-vapi
+ source = git://github.com/desiderantes/sdl2_vapi.git
+ source = INSTALL-path.patch
+ md5sums = SKIP
+ md5sums = 359dad346b5091c64f7d1d155b6d3f9e
+
+pkgname = sdl2-vapi-git
+
diff --git a/INSTALL-path.patch b/INSTALL-path.patch
new file mode 100644
index 000000000000..834c9f61cb78
--- /dev/null
+++ b/INSTALL-path.patch
@@ -0,0 +1,8 @@
+--- INSTALL 2015-04-12 08:01:59.940901623 +0200
++++ INSTALL.new 2015-04-12 08:02:24.357436014 +0200
+@@ -1,4 +1,4 @@
+ #!/usr/bin/sh
+-export VAPI_PATH="/usr/share/vala/vapi/"
++export VAPI_PATH="$1"
+ mkdir "$VAPI_PATH" -p
+ cp ./*.vapi "$VAPI_PATH" -R --force
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc5ccd54564f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Tomas Jasek <tomsik68(at)gmail(dot)com>
+
+pkgname=sdl2-vapi-git
+pkgver=b8ce044
+pkgrel=3
+pkgdesc="SDL2 Bindings for vala language"
+arch=('i686' 'x86_64')
+url="https://github.com/desiderantes/sdl2_vapi"
+license=('GPL')
+groups=()
+depends=('vala' 'sdl2')
+makedepends=(git)
+optdepends=('sdl2_gfx: SDL Graphic Primitives'
+ 'sdl2_image: A simple library to load images of various formats as SDL surfaces'
+ 'sdl2_mixer: A simple multi-channel audio mixer'
+ 'sdl2_net: A small sample cross-platform networking library'
+ 'sdl2_ttf: A library that allows you to use TrueType fonts in your SDL applications')
+provides=(sdl2-vapi)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=('git://github.com/desiderantes/sdl2_vapi.git' 'INSTALL-path.patch')
+md5sums=('SKIP' '359dad346b5091c64f7d1d155b6d3f9e')
+noextract=()
+
+build() {
+ cd $srcdir/sdl2_vapi
+ # patch the INSTALL file to install to directory given by an argument to the script
+ patch INSTALL $srcdir/INSTALL-path.patch
+}
+
+package() {
+ cd $srcdir/sdl2_vapi
+ # give the INSTALL file execute permission
+ chmod +x INSTALL
+ ./INSTALL $pkgdir/usr/share/vala/vapi
+ msg2 "This package also adds bindings for other SDL2 submodules like SDL_net, SDL_image or SDL_mixer. To use these submodules, you need to install them first - they're in optional dependencies."
+}