summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-05-27 16:10:39 -0400
committeréclairevoyant2023-05-27 16:10:39 -0400
commit2631bdb4365fc7b5dce3d6e29c6b6ca0b3d43f02 (patch)
tree75aec3c59c4e6237d075b0a77b314671b2f1caad
parenta4e9bff6e09a27dc275774af3d0a81e5d864aa37 (diff)
downloadaur-2631bdb4365fc7b5dce3d6e29c6b6ca0b3d43f02.tar.gz
fix deps, arch, source; clean up package()
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD50
3 files changed, 33 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6603f0184b78..f98e73a794ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = dwmbar-git
- pkgdesc = Simple and modular status bar for dwm.
- pkgver = 0.r74.
+ pkgdesc = Simple and modular status bar for dwm
+ pkgver = 0.r201.f112628
pkgrel = 1
- url = https://github.com/thytom/dwmbar.git
+ url = https://github.com/thytom/dwmbar
arch = any
- license = GPL
+ license = GPL3
makedepends = git
+ depends = bash
optdepends = dwm
- provides = dwmbar
- source = git://github.com/thytom/dwmbar.git
- md5sums = SKIP
- sha1sums = SKIP
- sha256sums = SKIP
+ source = git+https://github.com/thytom/dwmbar.git
+ b2sums = SKIP
pkgname = dwmbar-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..713f6f80aff8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 6f026a8ad5f7..af938ce6722d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,30 @@
-# Maintainer: Manuel Palenzuela <sadshinobi@protonmail.com>
+# Maintainer: éclairevoyant
+# Contributor: Manuel Palenzuela <sadshinobi at protonmail dot com>
-author=thytom
-pkgname=dwmbar-git
-_gitname=dwmbar
-pkgver=0.r74.
+_pkgname=dwmbar
+pkgname="$_pkgname-git"
+pkgver=0.r201.f112628
pkgrel=1
-pkgdesc='Simple and modular status bar for dwm.'
-url='https://github.com/thytom/dwmbar.git'
-arch=('any')
-license=('GPL')
-optdepends=('dwm')
-makedepends=('git')
-provides=('dwmbar')
-
-source=("git://github.com/$author/$_gitname.git")
-
-md5sums=('SKIP')
-sha1sums=('SKIP')
-sha256sums=('SKIP')
+pkgdesc='Simple and modular status bar for dwm'
+# some of the modules are x86_64 ELFs
+arch=(x86_64)
+url="https://github.com/thytom/$_pkgname"
+license=(GPL3)
+depends=(bash)
+makedepends=(git)
+optdepends=(dwm)
+source=("git+$url.git")
+b2sums=('SKIP')
pkgver() {
- cd "$_gitname"
- printf '0.r%s.%s' \
- "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ printf '0.r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$srcdir/$_gitname"
- # Install the program.
- mkdir -p "$pkgdir/usr/share/$_gitname/modules"
- install -Dm755 dwmbar "$pkgdir/usr/bin/$_gitname"
- cp -a --no-preserve=ownership {config,bar.sh,modules} "$pkgdir/usr/share/$_gitname"
- chmod +x "$pkgdir/usr/bin/$_gitname"
-# chmod -R 777 "$pkgdir/usr/share/$_gitname"
+ cd $_pkgname
+ install -vDm755 $_pkgname -t "$pkgdir/usr/bin/"
+
+ install -vdm755 "$pkgdir/usr/share/$_pkgname/"
+ cp -a --no-preserve=ownership {config,bar.sh,modules} "$pkgdir/usr/share/$_gitname"
}