summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2018-12-21 22:57:13 -0500
committerEric Berquist2018-12-21 22:57:13 -0500
commit2633c7f8d76c85770f71ce3f79655f0360465443 (patch)
treeebc83a62af334c93a71190e1c32d70939eae5656
parentc059eb8c4a50dc35b5f5bd03dc5f008fc350ef15 (diff)
downloadaur-2633c7f8d76c85770f71ce3f79655f0360465443.tar.gz
Refresh PKGBUILD from 2.4.2
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD22
3 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3276c8bcf6f..62167abe773f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
pkgbase = openbabel-git
pkgdesc = A library designed to interconvert between many file formats used in molecular modeling and computational chemistry (git version, builds Python bindings)
- pkgver = 2.3.90.r4215.3dda994
+ pkgver = 2.4.90.r5252.722b2134
pkgrel = 1
- url = http://openbabel.org/wiki/Main_Page
- arch = i686
+ url = https://github.com/openbabel/openbabel
arch = x86_64
license = GPL
makedepends = git
makedepends = cmake
- makedepends = eigen2
- makedepends = wxgtk2.8
+ makedepends = eigen
makedepends = boost
makedepends = swig
- makedepends = python
depends = libxml2
depends = libsm
- optdepends = eigen2: to use bindings
- optdepends = wxgtk2.8: GUI interface
+ depends = python
+ depends = wxgtk
provides = openbabel
conflicts = openbabel
conflicts = python-openbabel
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..415c89c16029
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# makepkg files
+pkg/
+src/
+*.xz
+
+# source files
+openbabel/
diff --git a/PKGBUILD b/PKGBUILD
index 18a5c9f6e281..decc4067e339 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,17 @@
# Maintainer: Eric Berquist <eric dot berquist at gmail dot com>
-
-# Based off the ABS PKGBUILD in [extra]/openbabel.
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
pkgname=openbabel-git
_name=openbabel
-pkgver=2.3.90.r4215.3dda994
+pkgver=2.4.90.r5252.722b2134
pkgrel=1
pkgdesc="A library designed to interconvert between many file formats used in molecular modeling and computational chemistry (git version, builds Python bindings)"
-arch=("i686" "x86_64")
-url="http://openbabel.org/wiki/Main_Page"
+arch=("x86_64")
+url="https://github.com/openbabel/openbabel"
license=("GPL")
-depends=("libxml2" "libsm")
-makedepends=("git" "cmake" "eigen2" "wxgtk2.8" "boost" "swig" "python")
-optdepends=("eigen2: to use bindings"
- "wxgtk2.8: GUI interface")
+depends=("libxml2" "libsm" "python" "wxgtk")
+makedepends=("git" "cmake" "eigen" "boost" "swig")
provides=("${_name}")
conflicts=("${_name}" "python-${_name}")
source=("${_name}::git+https://github.com/openbabel/openbabel.git#branch=master")
@@ -47,7 +45,7 @@ build() {
cmake "${srcdir}/${_name}" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-2.8 \
+ -DENABLE_OPENMP=ON \
-DRUN_SWIG=ON \
-DPYTHON_BINDINGS=ON
@@ -61,6 +59,8 @@ check() {
}
package() {
- cd "${srcdir}/build"
+ cd "${srcdir}"/build
+ make DESTDIR="${pkgdir}" install
+ cd "${srcdir}"/build/scripts
make DESTDIR="${pkgdir}" install
}