summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2020-11-17 10:45:04 +0100
committerD3SOX2020-11-17 10:45:04 +0100
commit263699d6a950e89bdbfa892c3742b5a0218f410d (patch)
treea1933887dc23cc0801c63425aec94ba6a0cdae9e
parent93641907c44ac7c2beacad161e13269692c2a7e4 (diff)
downloadaur-263699d6a950e89bdbfa892c3742b5a0218f410d.tar.gz
update to 7.1.5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD29
2 files changed, 16 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90566359fb8e..455634f89b4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = lazpaint-bin
pkgdesc = Image editor, like PaintBrush or Paint.Net, written in Lazarus (Free Pascal). Binary release (GTK2)
- pkgver = 7.0.7
+ pkgver = 7.1.5
pkgrel = 1
- url = http://sourceforge.net/projects/lazpaint/
+ url = https://lazpaint.github.io/
arch = x86_64
license = GPL3
- license = LGPL
depends = gtk2
depends = desktop-file-utils
provides = lazpaint
conflicts = lazpaint-qt4
conflicts = lazpaint-gtk2
- source = https://github.com/bgrabitmap/lazpaint/releases/download/v7.0.7/lazpaint7.0.7_linux64.deb
- sha256sums = SKIP
+ source = https://github.com/bgrabitmap/lazpaint/releases/download/v7.1.5/lazpaint7.1.5_linux64.deb
+ sha256sums = 2043e5e104101e8bf2005f64971b31e4cafa8e76ec5803f780d63f39c7d5ff9c
pkgname = lazpaint-bin
diff --git a/PKGBUILD b/PKGBUILD
index d70a434ba41d..f4219321fe0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,22 @@
-# Maintainer: Alex Gagne [SpectralMemories] <aaalex12gagne@gmail.com>
+# Maintainer: Nico <d3sox at protonmail dot com>
+# Contributor: Alex Gagne [SpectralMemories] <aaalex12gagne@gmail.com>
pkgname=lazpaint-bin
_pkgname=lazpaint
-pkgver=7.0.7
+pkgver=7.1.5
pkgrel=1
pkgdesc='Image editor, like PaintBrush or Paint.Net, written in Lazarus (Free Pascal). Binary release (GTK2)'
-arch=(x86_64)
-url='http://sourceforge.net/projects/lazpaint/'
-license=(GPL3 LGPL)
-depends=(gtk2 desktop-file-utils)
+arch=('x86_64')
+url='https://lazpaint.github.io/'
+license=('GPL3')
+depends=('gtk2' 'desktop-file-utils')
provides=("${_pkgname}")
conflicts=("${_pkgname}-qt4" "${_pkgname}-gtk2")
-source=("https://github.com/bgrabitmap/lazpaint/releases/download/v7.0.7/lazpaint7.0.7_linux64.deb")
-sha256sums=(SKIP)
-prepare() {
- cd $srcdir
- tar xf data.tar.xz
-}
+source=("https://github.com/bgrabitmap/${_pkgname}/releases/download/v${pkgver}/lazpaint${pkgver}_linux64.deb")
+sha256sums=('2043e5e104101e8bf2005f64971b31e4cafa8e76ec5803f780d63f39c7d5ff9c')
package() {
- cd $srcdir
-
- cp -Rf ./usr $pkgdir
-
- chmod a+x $pkgdir/usr/bin/lazpaint
+ cd "${pkgdir}"
+ # this extracts all into the pkgdir
+ tar xf "${srcdir}/data.tar.xz"
}