summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDustin Falgout2017-11-06 01:29:41 -0600
committerDustin Falgout2017-11-06 01:29:41 -0600
commit26550ba835122446e7e2011a2f5faabac57d7460 (patch)
treea54c24b4400452ae437e454a9d2579214f297e7d
parent9ea7167127806d6bb0f2a7bf0c1ad0e0066e1cb4 (diff)
downloadaur-26550ba835122446e7e2011a2f5faabac57d7460.tar.gz
[updpkg] v0.5.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1ddfbae16ac..9d0ddc1896b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jun 11 15:00:57 UTC 2017
+# Mon Nov 6 07:29:28 UTC 2017
pkgbase = brisk-menu
pkgdesc = Modern, efficient menu for the MATE Desktop Environment.
- pkgver = 0.4.5
+ pkgver = 0.5.0
pkgrel = 1
url = https://github.com/solus-project/brisk-menu
arch = i686
@@ -10,9 +10,10 @@ pkgbase = brisk-menu
groups = mate
license = GPL2
makedepends = gnome-common
+ makedepends = meson
depends = mate-panel
- source = https://github.com/solus-project/brisk-menu/releases/download/v0.4.5/brisk-menu-0.4.5.tar.xz
- md5sums = f420a9185e6b3dc930a42da36dc8b612
+ source = https://github.com/solus-project/brisk-menu/releases/download/v0.5.0/brisk-menu-v0.5.0.tar.xz
+ md5sums = 7230dba13a9ddb15cc5d6d7e16ac6e16
pkgname = brisk-menu
diff --git a/PKGBUILD b/PKGBUILD
index 2f0097210560..7d99b339d755 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dustin Falgout <dustin@antergos.com>
pkgname=brisk-menu
-pkgver=0.4.5
+pkgver=0.5.0
pkgrel=1
pkgdesc='Modern, efficient menu for the MATE Desktop Environment.'
arch=('i686' 'x86_64')
@@ -9,28 +9,27 @@ url='https://github.com/solus-project/brisk-menu'
license=('GPL2')
groups=('mate')
depends=('mate-panel')
-makedepends=('gnome-common')
-source=("https://github.com/solus-project/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz")
-md5sums=('f420a9185e6b3dc930a42da36dc8b612')
+makedepends=('gnome-common' 'meson')
+source=("https://github.com/solus-project/${pkgname}/releases/download/v${pkgver}/${pkgname}-v${pkgver}.tar.xz")
+md5sums=('7230dba13a9ddb15cc5d6d7e16ac6e16')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+ mkdir build
- ./configure \
+ meson build \
--prefix=/usr \
--bindir=/usr/bin \
- --sbindir=/usr/bin \
- --libdir=/usr/lib \
--libexecdir=/usr/lib/${pkgname}
- make
+ ninja -C build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-v${pkgver}/build"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
}