summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:42:06 +0200
committerM0Rf302015-06-17 16:42:06 +0200
commit26595b396e1b9d06ab4d54ddbb742011e45befb0 (patch)
treeaae0f415c6e5fd9a9e03d5941cfa86477332a62a
downloadaur-26595b396e1b9d06ab4d54ddbb742011e45befb0.tar.gz
Initial import
-rw-r--r--.AURINFO20
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
3 files changed, 83 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..645fa7e6818b
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,20 @@
+pkgbase = wifiphisher
+ pkgdesc = Fast automated phishing attacks against WPA networks.
+ pkgver = 12.73f24a7
+ pkgrel = 1
+ url = https://github.com/sophron/wifiphisher
+ arch = any
+ groups = blackarch
+ groups = blackarch-wireless
+ groups = blackarch-social
+ license = MIT
+ makedepends = git
+ depends = python2
+ depends = python2-httplib2
+ depends = scapy
+ depends = aircrack-ng
+ source = git+https://github.com/sophron/wifiphisher.git
+ sha1sums = SKIP
+
+pkgname = wifiphisher
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..645fa7e6818b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = wifiphisher
+ pkgdesc = Fast automated phishing attacks against WPA networks.
+ pkgver = 12.73f24a7
+ pkgrel = 1
+ url = https://github.com/sophron/wifiphisher
+ arch = any
+ groups = blackarch
+ groups = blackarch-wireless
+ groups = blackarch-social
+ license = MIT
+ makedepends = git
+ depends = python2
+ depends = python2-httplib2
+ depends = scapy
+ depends = aircrack-ng
+ source = git+https://github.com/sophron/wifiphisher.git
+ sha1sums = SKIP
+
+pkgname = wifiphisher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62bf126d2932
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This file is part of BlackArch Linux ( http://blackarch.org ).
+# See COPYING for license details.
+
+pkgname='wifiphisher'
+pkgver=12.73f24a7
+pkgrel=1
+groups=('blackarch' 'blackarch-wireless' 'blackarch-social')
+pkgdesc='Fast automated phishing attacks against WPA networks.'
+arch=('any')
+url='https://github.com/sophron/wifiphisher'
+license=('MIT')
+depends=('python2' 'python2-httplib2' 'scapy' 'aircrack-ng')
+makedepends=('git')
+source=('git+https://github.com/sophron/wifiphisher.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/wifiphisher"
+
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "$srcdir/wifiphisher"
+
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/wifiphisher"
+
+ install -Dm644 README.md "$pkgdir/usr/share/doc/wifiphisher/README.md"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/wifiphisher"
+
+ rm README.md LICENSE
+
+ cp -a * "$pkgdir/usr/share/wifiphisher"
+
+ cat > "$pkgdir/usr/bin/wifiphisher" << EOF
+#!/bin/sh
+cd /usr/share/wifiphisher
+exec python2 wifiphisher.py "\$@"
+EOF
+
+ chmod a+x "$pkgdir/usr/bin/wifiphisher"
+}