summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdvinas Valatka2019-10-23 01:24:17 +0300
committerEdvinas Valatka2019-10-23 01:24:17 +0300
commit266efac0de95d0be92f3222dd5f6458a841e9a8a (patch)
tree7f2d0d35b7a6292ce019b455cdae945a71481cfa
downloadaur-266efac0de95d0be92f3222dd5f6458a841e9a8a.tar.gz
Import from ABS
-rw-r--r--.SRCINFO22
-rw-r--r--LICENCE23
-rw-r--r--PKGBUILD42
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..162a36d06ab3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python2-openpyxl
+ pkgdesc = A Python library to read/write Excel 2007 xlsx/xlsm files
+ pkgver = 2.6.2
+ pkgrel = 2
+ url = https://openpyxl.readthedocs.org/
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ makedepends = python2-jdcal
+ makedepends = python2-et-xmlfile
+ source = python2-openpyxl-2.6.2.tar.bz2::https://bitbucket.org/openpyxl/openpyxl/get/2.6.2.tar.bz2
+ source = LICENCE
+ sha256sums = 7935ee3b99f9e6c5c105e38cae710f5872241d3c0c63a937f7097b4a2c05e83a
+ sha256sums = 0c84bb42f5d367e5ebf9fc2dde35b16141df5ee0fdc189250858bc6c5560f69e
+
+pkgname = python2-openpyxl
+ depends = python2-jdcal
+ depends = python2-et-xmlfile
+ optdepends = python2-pillow: needed to include images
+ optdepends = python2-lxml: alternative XML backend
+ optdepends = python2-defusedxml: guard against various XML vulnerabilities
+
diff --git a/LICENCE b/LICENCE
new file mode 100644
index 000000000000..82213c597d9f
--- /dev/null
+++ b/LICENCE
@@ -0,0 +1,23 @@
+This software is under the MIT Licence
+======================================
+
+Copyright (c) 2010 openpyxl
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc5533fc2c33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: Nishit Joseph (reachjlight at gmail dot com)
+# Contributor: Martin Corley <Martin.Corley@ed.ac.uk>
+
+pkgname=python2-openpyxl
+pkgver=2.6.2
+_pkgtag='3640394bff97'
+pkgrel=2
+pkgdesc="A Python library to read/write Excel 2007 xlsx/xlsm files"
+arch=('any')
+url="https://openpyxl.readthedocs.org/"
+license=('MIT')
+makedepends=('python2-setuptools' 'python2-jdcal' 'python2-et-xmlfile')
+source=("$pkgname-$pkgver.tar.bz2::https://bitbucket.org/openpyxl/openpyxl/get/${pkgver}.tar.bz2"
+ "LICENCE")
+sha256sums=('7935ee3b99f9e6c5c105e38cae710f5872241d3c0c63a937f7097b4a2c05e83a'
+ '0c84bb42f5d367e5ebf9fc2dde35b16141df5ee0fdc189250858bc6c5560f69e')
+
+prepare() {
+ cd openpyxl-openpyxl-${_pkgtag}
+
+ sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
+ -i $(find . -name '*.py')
+}
+
+build() {
+ cd openpyxl-openpyxl-${_pkgtag}
+ python2 setup.py build
+}
+
+package() {
+ depends=('python2-jdcal' 'python2-et-xmlfile')
+ optdepends=('python2-pillow: needed to include images'
+ 'python2-lxml: alternative XML backend'
+ 'python2-defusedxml: guard against various XML vulnerabilities')
+ cd openpyxl-openpyxl-${_pkgtag}
+ python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -Dm644 "$srcdir"/LICENCE "$pkgdir"/usr/share/licenses/$pkgname/LICENCE
+}
+