summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohnny Halfmoon2018-06-23 10:41:30 +0200
committerJohnny Halfmoon2018-06-23 10:44:29 +0200
commit269ff5d599a9a57305749fbe932cfc3c63fc3f15 (patch)
tree54d9270d1bb2ff46d4e74e7d7f377445be3656cb
downloadaur-269ff5d599a9a57305749fbe932cfc3c63fc3f15.tar.gz
inital commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--blheli-configurator.desktop7
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f82ef47e195
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = blheli-configurator
+ pkgdesc = Crossplatform configuration tool for BLHeli based ESCs
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/betaflight/betaflight-configurator
+ arch = x86_64
+ license = custom
+ provides = blheli-configurator
+ options = !strip
+ source = https://github.com/blheli-configurator/blheli-configurator/releases/download/1.1.0/BLHeli-Configurator_linux64_1.1.0.zip
+ source = https://github.com/blheli-configurator/blheli-configurator/blob/master/images/icon_128.png
+ source = blheli-configurator.desktop
+ md5sums = 35ba8814c2701327823f5a6ada974bcf
+ md5sums = 19cccd779bb0a997e8b86103cfdf440e
+ md5sums = d3f44aeb4a87d478aa9421c8c0206a11
+
+pkgname = blheli-configurator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1f4be0a2d57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Johnny Halfmoon < jhalfmoon at milksnot dot com >
+
+pkgname=blheli-configurator
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Crossplatform configuration tool for BLHeli based ESCs"
+arch=('x86_64')
+url="https://github.com/betaflight/betaflight-configurator"
+source=(
+"https://github.com/blheli-configurator/blheli-configurator/releases/download/$pkgver/BLHeli-Configurator_linux64_"$pkgver".zip"
+"https://github.com/blheli-configurator/blheli-configurator/blob/master/images/icon_128.png"
+"blheli-configurator.desktop"
+)
+
+md5sums=('35ba8814c2701327823f5a6ada974bcf'
+ '19cccd779bb0a997e8b86103cfdf440e'
+ 'd3f44aeb4a87d478aa9421c8c0206a11')
+options=(!strip)
+license=('custom')
+provides=("$pkgname")
+
+package() {
+ mkdir -p "$pkgdir/opt/blheli"
+ mkdir -p "$pkgdir/usr/bin"
+ #install -Dm644 "$srcdir/Betaflight Configurator/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/blheli-configurator.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "icon_128.png" "$pkgdir/opt/blheli-configurator/blheli_icon_128.png"
+ cp -r --preserve=all "$srcdir/BLHeli Configurator" "$pkgdir/opt/blheli-configurator"
+ ln -s "$pkgdir/opt/blheli-configurator/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/blheli-configurator.desktop b/blheli-configurator.desktop
new file mode 100644
index 000000000000..3f177ea32ac6
--- /dev/null
+++ b/blheli-configurator.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=BLHeli Configurator
+Comment=Crossplatform configuration tool for BLHeli based ESCs
+Exec=/opt/blheli-configurator/blheli-configurator
+Icon=/opt/blheli-configurator/blheli_icon_128.png
+Terminal=false
+Type=Application