summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2021-04-13 21:53:17 -0400
committerTony Lambiris2021-04-13 21:53:17 -0400
commit26b8bb2c4aceb3029714922d9876909aa61b9542 (patch)
tree425ec29ff29b4db2c91313ae635e138a53fcf284
parent391b0351bbb0ba2bfa7f0c64954137141766e6df (diff)
downloadaur-26b8bb2c4aceb3029714922d9876909aa61b9542.tar.gz
Change upstream repo.
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c24eda9a6f36..99965ee32039 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,13 +2,13 @@ pkgbase = gnome-shell-extension-bumblebee-status-git
pkgdesc = GNOME Shell extension that shows the status of the NVIDIA GPU
pkgver = r14.17cd4c1
pkgrel = 1
- url = https://github.com/dsboger/gnome-shell-extension-bumblebee-status
+ url = https://github.com/heatray/gnome-shell-extension-bumblebee-status
arch = any
license = GPL3
makedepends = git
depends = gnome-shell
depends = unzip
- source = git+https://github.com/dsboger/gnome-shell-extension-bumblebee-status.git
+ source = gnome-shell-extension-bumblebee-status-git::git+https://github.com/heatray/gnome-shell-extension-bumblebee-status
sha256sums = SKIP
pkgname = gnome-shell-extension-bumblebee-status-git
diff --git a/.gitignore b/.gitignore
index c0ea3cc5d240..6d277ef1a1eb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
src
pkg
-gnome-shell-extension-bumblebee-status
-*pkg.tar.xz
+gnome-shell-extension-bumblebee-status-git
+*.pkg.tar.*
tags
diff --git a/PKGBUILD b/PKGBUILD
index eca1c10ab139..1d7231091916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,34 @@
# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=gnome-shell-extension-bumblebee-status-git
-_gitname=gnome-shell-extension-bumblebee-status
pkgver=r14.17cd4c1
pkgrel=1
pkgdesc="GNOME Shell extension that shows the status of the NVIDIA GPU"
arch=('any')
-url="https://github.com/dsboger/gnome-shell-extension-bumblebee-status"
+url="https://github.com/heatray/gnome-shell-extension-bumblebee-status"
license=('GPL3')
depends=('gnome-shell' 'unzip')
makedepends=('git')
-source=('git+https://github.com/dsboger/gnome-shell-extension-bumblebee-status.git')
+source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
pkgver() {
- cd $_gitname
+ cd "${srcdir}/${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $_gitname
+ cd "${srcdir}/${pkgname}"
./autogen.sh
./configure --prefix=/usr
- make ${MAKEFLAGS} zip-file
+ make
}
package() {
- cd $_gitname
+ cd "${srcdir}/${pkgname}"
- _extid="gnome-shell-extension-bumblebee-status.dsboger@gmail.com"
- _extpath="${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
-
- install -dm755 "${_extpath}"
-
- unzip -q -d "${_extpath}" "${_gitname}.zip"
+ make DESTDIR="${pkgdir}" install
}