summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Minnocci2021-06-24 18:19:22 +0200
committerFrancesco Minnocci2021-06-24 18:19:22 +0200
commit26db9a9b2a21f707f874704bae62e6529403f76b (patch)
treea828adad982adade800274e1feb9bc6bd7d206d6
parent5545271d2f87923a0354b8856f0cef8bdd50e9da (diff)
downloadaur-26db9a9b2a21f707f874704bae62e6529403f76b.tar.gz
Update checksums
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--exiftool.patch30
3 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ed0363e0d91..04adb769930f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kunst-git
pkgdesc = kunst is a daemon that extracts the album art from the songs playing in mpd.
pkgver = 20200821
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/sdushantha/kunst
arch = any
license = MIT
@@ -17,7 +17,7 @@ pkgbase = kunst-git
provides = kunst
source = git+https://github.com/sdushantha/kunst.git
source = exiftool.patch
- sha256sums = SKIP
- sha256sums = a6932c0d233e295eaf7f43cc8d0ac9a3c4b541c82020c060141c9a6868aadd8f
+ sha512sums = SKIP
+ sha512sums = 94e554c8e13bc8c9b9d12ee904545a66c3b984dc2083d5103f82746b783719c505694092f0271f4ea165e0e229184fc11e99dae96cb2f0ab9788b61567cf4f9d
pkgname = kunst-git
diff --git a/PKGBUILD b/PKGBUILD
index 6a461bd0cf2a..17f467047d48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=kunst-git
_pkgname=kunst
-pkgver=20200821
-pkgrel=4
+pkgver=20210624
+pkgrel=1
pkgdesc="kunst is a daemon that extracts the album art from the songs playing in mpd."
arch=('any')
url="https://github.com/sdushantha/kunst"
diff --git a/exiftool.patch b/exiftool.patch
index 0bfa8947c254..8fa2f9470367 100644
--- a/exiftool.patch
+++ b/exiftool.patch
@@ -1,10 +1,10 @@
--- kunst/kunst 2021-02-02 12:40:50.127158706 +0100
+++ /usr/bin/kunst 2021-02-02 12:33:26.573815292 +0100
@@ -9,10 +9,12 @@
-
+
VERSION=1.3.2
COVER=/tmp/kunst.jpg
--MUSIC_DIR=~/Music/
+-MUSIC_DIR=~/Music
-SIZE=250x250
-POSITION="+0+0"
ONLINE_ALBUM_ART=false
@@ -13,11 +13,11 @@
+POSITION=${KUNST_POSITION:-"+0+0"}
+COVER_NAMES=${KUNST_COVER_NAMES:-"folder|cover|front"}
+COVER_EXT=${KUNST_COVER_EXT:-"jpg|png"}
-
+
show_help() {
printf "%s" "\
@@ -138,33 +140,52 @@
-
+
# Extract the album art from the mp3 file and dont show the messsy
# output of ffmpeg
- ffmpeg -i "$MUSIC_DIR$(mpc current -f %file%)" "$COVER" -y &> /dev/null
@@ -38,11 +38,11 @@
+ else
+ ffmpeg -i "$MUSIC_DIR/$(mpc current -f %file%)" "$COVER" -y &> /dev/null
+ fi
-
+
- # Get the status of the previous command
- STATUS=$?
+ STATUS=$?
-
+
# Check if the file has a embbeded album art
if [ "$STATUS" -eq 0 ];then
- [ ! "$SILENT" ] && echo "kunst: extracted album art"
@@ -57,7 +57,7 @@
+ [ "$DIR" == "$MUSIC_DIR"/. ] && ARTLESS=true && return 1
+
+ [ ! "$SILENT" ] && echo "kunst: inspecting $DIR"
-
+
# Check if there is an album cover/art in the folder.
- # Look at issue #9 for more details
- for CANDIDATE in "$DIR/cover."{png,jpg}; do
@@ -78,7 +78,7 @@
+ fi
+ done < <(find "$DIR" -type f | grep -i -E -- "($COVER_NAMES).($COVER_EXT)")
fi
-
+
if [ "$STATUS" -ne 0 ];then
- [ ! "$SILENT" ] && echo "error: file does not have an album art"
+ [ ! "$SILENT" ] && echo "error: file does not have an album art"
@@ -88,31 +88,31 @@
@@ -200,10 +221,6 @@
}
done
-
+
- [ "$KUNST_MUSIC_DIR" != "" ] && MUSIC_DIR="$KUNST_MUSIC_DIR"
- [ "$KUNST_SIZE" != "" ] && SIZE="$KUNST_SIZE"
- [ "$KUNST_POSITION" != "" ] && POSITION="$KUNST_POSITION"
-
# Flag to run some commands only once in the loop
FIRST_RUN=true
-
+
@@ -211,12 +228,9 @@
update_cover
-
+
if [ "$ARTLESS" == true ];then
- # Dhange the path to COVER because the music note
- # image is a png not jpg
- COVER=/tmp/kunst.png
-
+
# Decode the base64 encoded image and save it
- # to /tmp/kunst.png
+ # to /tmp/kunst.jpg
echo "$MUSIC_NOTE" | base64 --decode > "$COVER"
fi
-
+
@@ -229,8 +243,9 @@
FIRST_RUN=false
-
+
# Display the album art using sxiv
- sxiv -g "$SIZE$POSITION" -b "$COVER" -N "Kunst" &
-
@@ -124,7 +124,7 @@
echo $! >/tmp/kunst.pid
@@ -251,4 +266,6 @@
trap "" SIGTSTP
-
+
trap pre_exit EXIT
+trap 'exit 1' TERM HUP INT
+trap 'exit 0' USR1