summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxr19982023-05-28 16:31:20 +0200
committerMaxr19982023-05-28 16:31:20 +0200
commit26f5e42c557a3703cf7c36f7bdc712327d0db3a9 (patch)
treee646ae8ab353c394d0f031281edb724ccf58c92d
parent4999de732bdbb90e04c9981151ce96dce84cdb32 (diff)
downloadaur-26f5e42c557a3703cf7c36f7bdc712327d0db3a9.tar.gz
Update to GCC 13.1 and libisl 0.26
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d299cc73e1a..7e69e64b8fd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = riscv64-unknown-elf-gcc
pkgdesc = The GNU Compiler Collection - cross compiler for 32bit and 64bit RISC-V bare-metal
- pkgver = 12.2.0
+ pkgver = 13.1.0
pkgrel = 2
url = http://gcc.gnu.org/
arch = i686
@@ -13,9 +13,9 @@ pkgbase = riscv64-unknown-elf-gcc
depends = libmpc
options = !emptydirs
options = !strip
- source = https://gcc.gnu.org/pub/gcc/releases/gcc-12.2.0/gcc-12.2.0.tar.xz
- source = https://libisl.sourceforge.io/isl-0.25.tar.xz
- sha256sums = e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff
- sha256sums = be7b210647ccadf90a2f0b000fca11a4d40546374a850db67adb32fad4b230d9
+ source = https://gcc.gnu.org/pub/gcc/releases/gcc-13.1.0/gcc-13.1.0.tar.xz
+ source = https://libisl.sourceforge.io/isl-0.26.tar.xz
+ sha256sums = 61d684f0aa5e76ac6585ad8898a2427aade8979ed5e7f85492286c4dfc13ee86
+ sha256sums = a0b5cb06d24f9fa9e77b55fabbe9a3c94a336190345c2555f9915bb38e976504
pkgname = riscv64-unknown-elf-gcc
diff --git a/PKGBUILD b/PKGBUILD
index 0bfc45c8a799..298330a261a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_target=riscv64-unknown-elf
pkgname=$_target-gcc
-pkgver=12.2.0
-_islver=0.25
+pkgver=13.1.0
+_islver=0.26
pkgrel=2
#_snapshot=7-20170504
pkgdesc='The GNU Compiler Collection - cross compiler for 32bit and 64bit RISC-V bare-metal'
@@ -15,8 +15,8 @@ depends=("$_target-binutils" 'zlib' 'libmpc')
options=(!emptydirs !strip)
source=("https://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.xz"
"https://libisl.sourceforge.io/isl-$_islver.tar.xz")
-sha256sums=('e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff'
- 'be7b210647ccadf90a2f0b000fca11a4d40546374a850db67adb32fad4b230d9')
+sha256sums=('61d684f0aa5e76ac6585ad8898a2427aade8979ed5e7f85492286c4dfc13ee86'
+ 'a0b5cb06d24f9fa9e77b55fabbe9a3c94a336190345c2555f9915bb38e976504')
if [[ -n "$_snapshot" ]]; then
_basedir=gcc-$_snapshot