summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos López Sánchez2015-07-23 22:15:44 -0500
committerCarlos López Sánchez2015-07-23 22:15:44 -0500
commit27176c55f71ec72fb3a937fde5b533cfa1e51583 (patch)
tree8aab94341499e5b0d70f649c15d55d2d923f2999
downloadaur-27176c55f71ec72fb3a937fde5b533cfa1e51583.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
-rw-r--r--faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch13
-rw-r--r--faad2-2.7-libmp4ff-shared-lib.patch29
-rw-r--r--faad2-2.7-man1_MANS.patch10
-rw-r--r--faad2-2.7-xmms-shared-lib.patch12
6 files changed, 135 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..652c6d4880f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = xmms-mp4-plugin
+ pkgdesc = ISO AAC audio decoder
+ pkgver = 2.7
+ pkgrel = 4
+ url = http://www.audiocoding.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ options = !makeflags
+ source = http://downloads.sourceforge.net/sourceforge/faac/faad2-2.7.tar.bz2
+ source = faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch
+ source = faad2-2.7-libmp4ff-shared-lib.patch
+ source = faad2-2.7-man1_MANS.patch
+ source = faad2-2.7-xmms-shared-lib.patch
+ sha256sums = 14561b5d6bc457e825bfd3921ae50a6648f377a9396eaf16d4b057b39a3f63b5
+ sha256sums = c554313121f935aaabbe5b05addfc065bdf782bc0634ee9a91ceabde001ea823
+ sha256sums = e0aaefeb20ebfec2f09e88a190f78e5744d9f1c71fe41977db8e4f29b5b88022
+ sha256sums = e3e745cca309443d0149a09cc9988fec09c51e242b0e564afcb0af787dbb9031
+ sha256sums = 1bc896c2454dafa954b5e658ead0604b12460441bc3f71d1b01a1c124650400a
+
+pkgname = xmms-mp4-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae094aa365d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Musikolo <musikoloAThotmailDOTcom>
+# Contributor: Eric Bélanger <eric@archlinux.org>
+# Contributor: Sarah Hay <sarah@archlinux.org>
+
+# This package is based on the Arch Linux official faad2 package built by Sarah Hay.
+# Thanks Sarah! It just builds the whole faad2 package in the same way, but it
+# includes the --with-xmms switch and put the libmp4.so file in a package.
+
+_srcname=faad2
+pkgname=xmms-mp4-plugin
+pkgver=2.7
+pkgrel=4
+pkgdesc="ISO AAC audio decoder"
+arch=('i686' 'x86_64')
+url="http://www.audiocoding.com/"
+license=('GPL')
+depends=('glibc')
+options=('!makeflags')
+source=(http://downloads.sourceforge.net/sourceforge/faac/${_srcname}-${pkgver}.tar.bz2
+ faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch
+ faad2-2.7-libmp4ff-shared-lib.patch
+ faad2-2.7-man1_MANS.patch
+ faad2-2.7-xmms-shared-lib.patch)
+sha256sums=('14561b5d6bc457e825bfd3921ae50a6648f377a9396eaf16d4b057b39a3f63b5'
+ 'c554313121f935aaabbe5b05addfc065bdf782bc0634ee9a91ceabde001ea823'
+ 'e0aaefeb20ebfec2f09e88a190f78e5744d9f1c71fe41977db8e4f29b5b88022'
+ 'e3e745cca309443d0149a09cc9988fec09c51e242b0e564afcb0af787dbb9031'
+ '1bc896c2454dafa954b5e658ead0604b12460441bc3f71d1b01a1c124650400a')
+
+prepare() {
+ cd ${_srcname}-${pkgver}
+ patch -p1 -i "${srcdir}/faad2-2.7-libmp4ff-shared-lib.patch"
+ patch -p0 -i "${srcdir}/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch"
+ patch -p1 -i "${srcdir}/faad2-2.7-man1_MANS.patch"
+ patch -p1 -i "${srcdir}/faad2-2.7-xmms-shared-lib.patch"
+ autoreconf --force --install
+}
+
+build() {
+ cd ${_srcname}-${pkgver}
+ ./configure --prefix=/usr --with-xmms
+ make CFLAGS="${CFLAGS} -fPIC"
+}
+
+package(){
+ cd ${srcdir}/${_srcname}-${pkgver}
+ install -D -m644 ${srcdir}/${_srcname}-${pkgver}/plugins/xmms/src/.libs/libmp4.so ${pkgdir}`xmms-config --input-plugin-dir`/libmp4.so
+}
diff --git a/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch b/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch
new file mode 100644
index 000000000000..5d39cad95d7e
--- /dev/null
+++ b/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch
@@ -0,0 +1,13 @@
+Install mp4ff_int_types.h for mythmusic.
+
+http://bugs.gentoo.org/275008
+
+--- common/mp4ff/Makefile.am
++++ common/mp4ff/Makefile.am
+@@ -1,5 +1,5 @@
+ lib_LTLIBRARIES = libmp4ff.la
+-include_HEADERS = mp4ff.h mp4ffint.h
++include_HEADERS = mp4ff.h mp4ffint.h mp4ff_int_types.h
+
+ AM_CFLAGS = -DUSE_TAGGING=1
+
diff --git a/faad2-2.7-libmp4ff-shared-lib.patch b/faad2-2.7-libmp4ff-shared-lib.patch
new file mode 100644
index 000000000000..56a131192969
--- /dev/null
+++ b/faad2-2.7-libmp4ff-shared-lib.patch
@@ -0,0 +1,29 @@
+Ripped from Debian
+
+Patch to create a shared lib for libmp4ff.
+
+--- a/common/mp4ff/Makefile.am
++++ b/common/mp4ff/Makefile.am
+@@ -1,7 +1,8 @@
+-lib_LIBRARIES = libmp4ff.a
++lib_LTLIBRARIES = libmp4ff.la
+ include_HEADERS = mp4ff.h mp4ffint.h
+
+-libmp4ff_a_CFLAGS = -DUSE_TAGGING=1
++AM_CFLAGS = -DUSE_TAGGING=1
+
+-libmp4ff_a_SOURCES = mp4ff.c mp4atom.c mp4meta.c mp4sample.c mp4util.c \
++libmp4ff_la_LDFLAGS = -version-info 0:0:0
++libmp4ff_la_SOURCES = mp4ff.c mp4atom.c mp4meta.c mp4sample.c mp4util.c \
+ mp4tagupdate.c mp4ff.h mp4ffint.h mp4ff_int_types.h
+--- a/frontend/Makefile.am
++++ b/frontend/Makefile.am
+@@ -5,7 +5,7 @@
+ -I$(top_srcdir)/common/mp4ff
+
+ faad_LDADD = $(top_builddir)/libfaad/libfaad.la \
+- $(top_builddir)/common/mp4ff/libmp4ff.a
++ $(top_builddir)/common/mp4ff/libmp4ff.la
+
+ faad_SOURCES = main.c \
+ audio.c audio.h \
diff --git a/faad2-2.7-man1_MANS.patch b/faad2-2.7-man1_MANS.patch
new file mode 100644
index 000000000000..9c1ddb01bc31
--- /dev/null
+++ b/faad2-2.7-man1_MANS.patch
@@ -0,0 +1,10 @@
+diff -ur faad2-2.7.orig/frontend/Makefile.am faad2-2.7/frontend/Makefile.am
+--- faad2-2.7.orig/frontend/Makefile.am 2009-02-06 18:03:37.000000000 +0200
++++ faad2-2.7/frontend/Makefile.am 2009-07-20 20:27:29.000000000 +0300
+@@ -1,5 +1,5 @@
+ bin_PROGRAMS = faad
+-man_MANS = faad.man
++man1_MANS = faad.man
+
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/common/faad \
+ -I$(top_srcdir)/common/mp4ff
diff --git a/faad2-2.7-xmms-shared-lib.patch b/faad2-2.7-xmms-shared-lib.patch
new file mode 100644
index 000000000000..aecafc07b934
--- /dev/null
+++ b/faad2-2.7-xmms-shared-lib.patch
@@ -0,0 +1,12 @@
+diff -Naur a/plugins/xmms/src/Makefile.am b/plugins/xmms/src/Makefile.am
+--- a/plugins/xmms/src/Makefile.am 2009-01-26 16:51:44.000000000 -0600
++++ b/plugins/xmms/src/Makefile.am 2015-06-24 23:15:27.782279146 -0500
+@@ -7,7 +7,7 @@
+ -I$(top_srcdir)/include -I$(top_srcdir)/common/mp4ff
+
+ libmp4_la_LIBADD = $(top_builddir)/libfaad/libfaad.la \
+- $(top_builddir)/common/mp4ff/libmp4ff.a
++ $(top_builddir)/common/mp4ff/libmp4ff.la
+
+ libmp4_la_LDFLAGS = -module -avoid-version $(local_LDFLAGS) -lpthread
+