summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2022-08-23 11:05:02 -0400
committeracxz2022-08-23 11:05:02 -0400
commit27190263ffb50bc5914ee2562e6bd94a0a86d88c (patch)
treeab7f300d06401e3cdcb43c03fc95e93056003360
parent4a2c092ac1dcc2617cdd57b13482eee7f4c28eac (diff)
downloadaur-27190263ffb50bc5914ee2562e6bd94a0a86d88c.tar.gz
upgpkg: python-ray 2.0.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 6 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ffb27e824a5..35778503ad6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ray
pkgdesc = A fast and simple framework for building and running distributed applications.
- pkgver = 1.13.1
+ pkgver = 2.0.0
pkgrel = 1
url = https://ray.io
arch = x86_64
@@ -58,11 +58,7 @@ pkgbase = python-ray
optdepends = python-scikit-image: for ray[rllib]
optdepends = python-pyaml: for ray[rllib]
optdepends = python-scipy: for ray[rllib]
- source = python-ray-1.13.1.tar.gz::https://github.com/ray-project/ray/archive/ray-1.13.1.tar.gz
- source = init_order.patch::https://github.com/ray-project/ray/commit/85fe5346c83233af8e3aa36a3a9e3001a05f972f.patch
- source = py310.patch::https://patch-diff.githubusercontent.com/raw/ray-project/ray/pull/21221.patch
- sha256sums = 085937d1873e3108e0f180abaeb4f73bee9450cf8753e683229da69d4ab4f985
- sha256sums = 539f9881e686281a71ca72d3a9a62c926960f400e36f3007d2bb8079b59fd07b
- sha256sums = SKIP
+ source = python-ray-2.0.0.tar.gz::https://github.com/ray-project/ray/archive/ray-2.0.0.tar.gz
+ sha256sums = 333841d6e8ad328e0bcbaa2a1adc4ea1ddb302016debb955acc23eeb121417bf
pkgname = python-ray
diff --git a/PKGBUILD b/PKGBUILD
index 5c539519a606..7aea858e9f86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-ray
-pkgver=1.13.1
+pkgver=2.0.0
pkgrel=1
pkgdesc='A fast and simple framework for building and running distributed
applications.'
@@ -49,22 +49,13 @@ optdepends=(
makedepends=(python python-build python-installer python-wheel python-setuptools
python-pip cython bazel)
_pkgname=ray
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ray-project/ray/archive/${_pkgname}-$pkgver.tar.gz"
- "init_order.patch"::"https://github.com/ray-project/ray/commit/85fe5346c83233af8e3aa36a3a9e3001a05f972f.patch"
- "py310.patch"::"https://patch-diff.githubusercontent.com/raw/ray-project/ray/pull/21221.patch")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ray-project/ray/archive/${_pkgname}-$pkgver.tar.gz")
-sha256sums=('085937d1873e3108e0f180abaeb4f73bee9450cf8753e683229da69d4ab4f985'
- '539f9881e686281a71ca72d3a9a62c926960f400e36f3007d2bb8079b59fd07b'
- 'SKIP')
+sha256sums=('333841d6e8ad328e0bcbaa2a1adc4ea1ddb302016debb955acc23eeb121417bf')
prepare() {
cd "${srcdir}/${_pkgname}-${_pkgname}-${pkgver}"
- patch --strip=1 < "${srcdir}/init_order.patch"
-
- #patch --strip=1 < "${srcdir}/py310.patch"
- sed -i "s/9)]/9), (3, 10)]/" python/setup.py
-
# https://aur.archlinux.org/packages/py-spy#comment-781521
sed -i "/py-spy/d" python/setup.py
}