summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-03-12 19:40:04 +0800
committerUniversebenzene2021-03-12 19:40:04 +0800
commit2726745ec547f61641e0cbf6978ce6f9ab19f7e8 (patch)
treecc2373cad42c2db672a54e287533657d4faafd73
parent289cefefe003e2bb220da0577b5a9876a1cb916a (diff)
downloadaur-2726745ec547f61641e0cbf6978ce6f9ab19f7e8.tar.gz
Update to version 2.2.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD10
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7ad5c959d95..0d329e1ca0b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = python-corner
pkgdesc = Make some beautiful corner plots of samples
- pkgver = 2.1.0
+ pkgver = 2.2.1
pkgrel = 1
- url = https://pypi.python.org/pypi/corner/
+ url = https://corner.readthedocs.io
arch = any
license = BSD
- depends = python-matplotlib
- depends = python-pytest
+ makedepends = python-setuptools-scm
+ depends = python-matplotlib>=2.1
depends = python-nose
depends = python-pandas
- depends = python-setuptools-scm
- depends = python-wheel
- source = https://files.pythonhosted.org/packages/source/c/corner/corner-2.1.0.tar.gz
- md5sums = 38f04719d1ab21d10e532f6d368ad22a
+ optdepends = python-scipy
+ optdepends = python-arviz>=0.9
+ optdepends = python-black
+ optdepends = python-isort
+ optdepends = python-toml
+ source = https://files.pythonhosted.org/packages/source/c/corner/corner-2.2.1.tar.gz
+ md5sums = 4fc5208462aa3e4ba83f1e874382e287
pkgname = python-corner
diff --git a/PKGBUILD b/PKGBUILD
index 4b7cd69aed0a..c85cecf182cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
_pyname=corner
pkgname=python-${_pyname}
-pkgver=2.1.0
+pkgver=2.2.1
pkgrel=1
pkgdesc='Make some beautiful corner plots of samples'
-url="https://pypi.python.org/pypi/$_pyname/"
-depends=('python-matplotlib' 'python-pytest' 'python-nose' 'python-pandas' 'python-setuptools-scm' 'python-wheel')
+url="https://corner.readthedocs.io"
+depends=('python-matplotlib>=2.1' 'python-nose' 'python-pandas')
+makedepends=('python-setuptools-scm')
+optdepends=('python-scipy' 'python-arviz>=0.9' 'python-black' 'python-isort' 'python-toml')
license=('BSD')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('38f04719d1ab21d10e532f6d368ad22a')
+md5sums=('4fc5208462aa3e4ba83f1e874382e287')
build() {
cd ${srcdir}/${_pyname}-${pkgver}