summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Giovannetti2018-11-25 02:53:40 +0800
committerDario Giovannetti2018-11-25 02:53:40 +0800
commit2731b7d6a07641fc8b63f9214fdd6f731c0f6fad (patch)
tree771265df5fd0048cdd4ee45ba2baa514683876b5
downloadaur-2731b7d6a07641fc8b63f9214fdd6f731c0f6fad.tar.gz
v1.2.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be4d1b9d642a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-flask-restinpeace
+ pkgdesc = Create Flask REST APIs in peace.
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/kynikos/lib.py.flask-rip
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-flask-marshmallow
+ depends = python-apispec
+ source = https://files.pythonhosted.org/packages/source/f/flask-restinpeace/flask-restinpeace-1.2.1.tar.gz
+ sha256sums = 4c585d271c270dfad1848c0fe157ff8b7d75dce4291414c817607219d0ea92c7
+
+pkgname = python-flask-restinpeace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8335051fcb0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Dario Giovannetti <dev at dariogiovannetti dot net>
+
+_name='flask-restinpeace'
+
+pkgname="python-${_name}"
+pkgver='1.2.1'
+pkgrel=1
+pkgdesc="Create Flask REST APIs in peace."
+arch=('any')
+url="https://github.com/kynikos/lib.py.flask-rip"
+license=('MIT')
+depends=('python-flask-marshmallow' 'python-apispec')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('4c585d271c270dfad1848c0fe157ff8b7d75dce4291414c817607219d0ea92c7')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}