summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2014-09-30 16:31:28 -0600
committerBrian Bidulock2015-06-10 16:08:32 -0600
commit277541e184423bef07738893fad599ed2c0e02da (patch)
tree68c42cec9537e3e5a99f05fd74afb73d0c056322
parentf67dbd89ad1cc545ebf2a0b5e850c2a770700642 (diff)
downloadaur-277541e184423bef07738893fad599ed2c0e02da.tar.gz
version 2.0.0-1
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--smcroute.conf.example11
4 files changed, 37 insertions, 10 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..403debc15079
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = smcroute
+ pkgdesc = A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://troglobit.com/smcroute.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ provides = smcroute
+ provides = mcsender
+ source = ftp://troglobit.com/smcroute/smcroute-2.0.0.tar.xz
+ source = smcroute.conf.example
+ source = smcroute.service
+ backup = etc/smcroute.conf
+
+pkgname = smcroute
+
diff --git a/.SRCINFO b/.SRCINFO
index 28d827d2a7be..530c41c159c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = smcroute
pkgdesc = A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing.
- pkgver = 1.99.2
+ pkgver = 2.0.0
pkgrel = 1
url = https://troglobit.com/smcroute.html
arch = i686
@@ -10,11 +10,11 @@ pkgbase = smcroute
provides = smcroute
provides = mcsender
backup = etc/smcroute.conf
- source = ftp://troglobit.com/smcroute/smcroute-1.99.2.tar.bz2
+ source = ftp://troglobit.com/smcroute/smcroute-2.0.0.tar.xz
source = smcroute.conf.example
source = smcroute.service
- md5sums = 47e2a8157b32a8b9aa34133878ffe3b5
- md5sums = 59fdb2baf1184d0cb5c59b576b1b5e1c
+ md5sums = cbf478e52ab9ae411adca41b9d22f68a
+ md5sums = 98bdb5bbd222686761e318ee04825b7a
md5sums = 7b28500642045b2482f5ac873da0f86b
pkgname = smcroute
diff --git a/PKGBUILD b/PKGBUILD
index d64ad961d466..5f8b261e8ac9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
# Contributor: Julien Sopena (jsopena.archlinux@free.fr)
pkgname="smcroute"
-pkgver="1.99.2"
+pkgver="2.0.0"
pkgrel=1
pkgdesc="A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing."
arch=('i686' 'x86_64')
@@ -10,11 +10,11 @@ license=('GPL2')
provides=('smcroute' 'mcsender')
backup=('etc/smcroute.conf')
depends=('glibc')
-source=("ftp://troglobit.com/smcroute/$pkgname-$pkgver.tar.bz2"
+source=("ftp://troglobit.com/smcroute/$pkgname-$pkgver.tar.xz"
'smcroute.conf.example'
'smcroute.service')
-md5sums=('47e2a8157b32a8b9aa34133878ffe3b5'
- '59fdb2baf1184d0cb5c59b576b1b5e1c'
+md5sums=('cbf478e52ab9ae411adca41b9d22f68a'
+ '98bdb5bbd222686761e318ee04825b7a'
'7b28500642045b2482f5ac873da0f86b')
build() {
@@ -29,6 +29,8 @@ package() {
install -Dm644 "${srcdir}/smcroute.conf.example" "${pkgdir}/etc/smcroute.conf"
install -Dm644 "${srcdir}/smcroute.service" "${pkgdir}/usr/lib/systemd/system/smcroute.service"
+ # nothing useful here
+ rm -fr "${pkgdir}/usr/share/doc"
}
# vim:set ts=2 sw=2 et:
diff --git a/smcroute.conf.example b/smcroute.conf.example
index b587fc706c39..d8b8d73cd54c 100644
--- a/smcroute.conf.example
+++ b/smcroute.conf.example
@@ -11,14 +11,21 @@
#
# Syntax:
# mgroup from IFNAME group MCGROUP
-# mroute from IFNAME source ADDRESS group MCGROUP to IFNAME [IFNAME ...]
+# mroute from IFNAME [source ADDRESS] group MCGROUP to IFNAME [IFNAME ...]
#
# The following example instructs the kernel to join the multicast
# group 225.1.2.3 on interface eth0. Followed by setting up an
# mroute of the same multicast stream, but from the explicit sender
# 192.168.1.42 on the eth0 network and forward to eth1 and eth2.
#
-
# mgroup from eth0 group 225.1.2.3
# mroute from eth0 group 225.1.2.3 source 192.168.1.42 to eth1 eth2
+# Here we allow routing of multicast to group 225.3.2.1 from ANY
+# source coming in from interface eth0 and forward to eth1 and eth2.
+# NOTE: Routing from ANY source is currently only available for IPv4
+# multicast.
+#
+# mgroup from eth0 group 225.3.2.1
+# mroute from eth0 group 225.3.2.1 to eth1 eth2
+