summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTerin Stock2019-11-04 11:30:28 -0800
committerTerin Stock2019-11-04 11:36:09 -0800
commit277de85243fe8d7121ec91df756d30a45da23307 (patch)
tree97f2c067f4982ee3760128c5ef9dafd649da7e9e
parentd50bceff180b0fb6e99b2a4acb4c7f29b00c9b27 (diff)
downloadaur-277de85243fe8d7121ec91df756d30a45da23307.tar.gz
topgit: version 0.19.12
Adds bash completions from the contrib directory.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52051955e60f..ee51878ba752 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = topgit
pkgdesc = A different patch queue manager
- pkgver = 0.19.11
+ pkgver = 0.19.12
pkgrel = 1
url = https://github.com/mackyle/topgit
arch = any
license = GPL2
depends = gawk
depends = bash
- source = https://github.com/mackyle/topgit/archive/topgit-0.19.11.tar.gz
- sha256sums = f799c007d937ace94aa3dd905695dfe36bed758149e36a8206334feae3dcc45a
+ source = https://github.com/mackyle/topgit/archive/topgit-0.19.12.tar.gz
+ sha256sums = 104eaf5b33bdc738a63603c4a661aab33fc59a5b8e3bb3bc58af7e4fc2d031da
pkgname = topgit
diff --git a/PKGBUILD b/PKGBUILD
index c5fab68c781c..094f0b40f176 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Terin Stock <terinjokes@gmail.com>
pkgname=topgit
-pkgver=0.19.11
+pkgver=0.19.12
pkgrel=1
pkgdesc="A different patch queue manager"
url="https://github.com/mackyle/topgit"
@@ -12,9 +12,11 @@ makedepends=()
source=(
"https://github.com/mackyle/topgit/archive/topgit-${pkgver}.tar.gz"
)
-sha256sums=('f799c007d937ace94aa3dd905695dfe36bed758149e36a8206334feae3dcc45a')
+sha256sums=('104eaf5b33bdc738a63603c4a661aab33fc59a5b8e3bb3bc58af7e4fc2d031da')
package() {
- cd "$pkgname-topgit-$pkgver"
- make prefix=/usr cmddir=/usr/lib/topgit DESTDIR="$pkgdir" install
+ cd "${pkgname}-topgit-${pkgver}" || exit 1
+ make prefix=/usr cmddir=/usr/lib/topgit DESTDIR="${pkgdir}" install
+
+ install -D -m644 contrib/tg-completion.bash "${pkgdir}/usr/share/bash-completion/completions/tg"
}