summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcopygirl2023-09-24 19:18:49 +0200
committercopygirl2023-09-24 19:18:49 +0200
commit278c28d21e51360b976981307e60811a24683acf (patch)
treebd649661cd89ff519515916635b4abc859734b8e
parentec390c973de41a744a5975a412e1964411abca7d (diff)
downloadaur-278c28d21e51360b976981307e60811a24683acf.tar.gz
New release 1.18.13
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 439b91cfd2c7..a305ecdcda3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vintagestory
pkgdesc = Uncompromising wilderness survival sandbox game (requires paid account)
- pkgver = 1.18.10
+ pkgver = 1.18.13
pkgrel = 2
url = https://www.vintagestory.at/
arch = x86_64
@@ -8,9 +8,9 @@ pkgbase = vintagestory
depends = dotnet-runtime
depends = opengl-driver
depends = openal
- source = https://cdn.vintagestory.at/gamefiles/stable/vs_client_linux-x64_1.18.10.tar.gz
+ source = https://cdn.vintagestory.at/gamefiles/stable/vs_client_linux-x64_1.18.13.tar.gz
source = vintagestory.desktop
- md5sums = e03b87841e67769297cb2fec79bfaa3d
+ md5sums = c8f2c4f19206a71d3a8af34069e89ba2
md5sums = 26ff9ca4fb0a583589f26f2c274d4ec6
pkgname = vintagestory
diff --git a/PKGBUILD b/PKGBUILD
index 84c3019d06d6..02e6f107a447 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=vintagestory
# "unstable" for release candidates and "pre" for testing releases before big updates.
_release=stable
# _pkgver is separate to allow specifying pre-release versions such as "-rc.1".
-_pkgver=1.18.10
+_pkgver=1.18.13
# makepkg doesn't support hyphens in pkgver. They'll be replaced with underscores.
pkgver=${_pkgver//-/_}
@@ -18,14 +18,14 @@ depends=("dotnet-runtime" "opengl-driver" "openal")
source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_client_linux-x64_$_pkgver.tar.gz"
# "https://account.vintagestory.at/files/$_release/vs_client_linux-x64_$_pkgver.tar.gz" (alternative source)
"vintagestory.desktop")
-md5sums=("e03b87841e67769297cb2fec79bfaa3d"
+md5sums=("c8f2c4f19206a71d3a8af34069e89ba2"
"26ff9ca4fb0a583589f26f2c274d4ec6")
prepare() {
# Remove install script provided by developers
rm "$pkgname"/install.sh
# Create symbolic links for any assets (excluding fonts) containing non-lowercase letters
- # Some asset files might include uppercase letters, but the game expects them to be all-lowercase
+ # Some asset files might include uppercase letters, but the game expects them to be lowercase
find "$pkgname"/assets/ -not -path "*/fonts/*" -regex ".*/.*[A-Z].*" | while read -r file; do
local filename="$(basename -- "$file")"
ln -sf "$filename" "${file%/*}"/"${filename,,}"
@@ -41,6 +41,6 @@ package() {
# Copy all other application files
cp -rdp --no-preserve=ownership "$pkgname" "$pkgdir"/usr/share/"$pkgname"
# Create a symlink to run the game from terminal
- install -dm 755 "${pkgdir}/usr/bin/" # Create directory first (required)
- ln -s "/usr/share/${pkgname}/Vintagestory" "${pkgdir}/usr/bin/${pkgname}"
+ install -dm 755 "$pkgdir"/usr/bin/ # Create directory first (required)
+ ln -s /usr/share/"$pkgname"/Vintagestory "$pkgdir"/usr/bin/"$pkgname"
}