summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422019-03-01 16:38:36 +0100
committerSkycoder422019-03-01 16:38:36 +0100
commit27b0e3e8457e161e350616dba782d41cc0ae7f9f (patch)
tree08e0bded055494de3cc349cea2efcda25e3b2ce3
parentc763d99c8372947ff03b8b3c8b4e95ebeda2bf1e (diff)
downloadaur-27b0e3e8457e161e350616dba782d41cc0ae7f9f.tar.gz
Updated to 1.1.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--qt5-apng-plugin.rule2
3 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b00955abb892..70f4c597ae2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = qt5-apng-plugin
- pkgdesc = apng image plugin for Qt to support animated PNGs
- pkgver = 1.1.0
+ pkgdesc = An apng image plugin for Qt to support animated PNGs
+ pkgver = 1.1.1
pkgrel = 1
- url = https://github.com/Skycoder42/qapng
+ url = https://github.com/Skycoder42/QtApng
arch = i686
arch = x86_64
license = BSD
@@ -11,10 +11,10 @@ pkgbase = qt5-apng-plugin
depends = qt5-base
depends = libpng
optdepends = repkg: Automatically rebuild the package on dependency updates
- source = qt5-apng-plugin-1.1.0::git+https://github.com/Skycoder42/qapng.git#tag=1.1.0
+ source = qt5-apng-plugin-1.1.1::git+https://github.com/Skycoder42/QtApng.git#tag=1.1.1
source = qt5-apng-plugin.rule
sha256sums = SKIP
- sha256sums = 536886c68918305f12db47b6d0e6fd2ebff8b6ac41ebdab7dc2985a23e739909
+ sha256sums = eaf4fe81c8521aeec2e0eca0a369542f914a8d57234d6edde6da8d5bb9bed505
pkgname = qt5-apng-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 90d5f80d03b6..90de472ac9d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=qt5-apng-plugin
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=1
-pkgdesc="apng image plugin for Qt to support animated PNGs"
+pkgdesc="An apng image plugin for Qt to support animated PNGs"
arch=('i686' 'x86_64')
-url="https://github.com/Skycoder42/qapng"
+url="https://github.com/Skycoder42/QtApng"
license=('BSD')
depends=('qt5-base' 'libpng')
makedepends=('git' 'qt5-tools')
optdepends=("repkg: Automatically rebuild the package on dependency updates")
_pkgfqn=$pkgname-$pkgver
-source=("$_pkgfqn::git+https://github.com/Skycoder42/qapng.git#tag=$pkgver"
+source=("$_pkgfqn::git+https://github.com/Skycoder42/QtApng.git#tag=$pkgver"
"$pkgname.rule")
sha256sums=('SKIP'
- '536886c68918305f12db47b6d0e6fd2ebff8b6ac41ebdab7dc2985a23e739909')
+ 'eaf4fe81c8521aeec2e0eca0a369542f914a8d57234d6edde6da8d5bb9bed505')
prepare() {
mkdir -p build
@@ -22,8 +22,7 @@ prepare() {
build() {
cd build
- qmake "../$_pkgfqn/"
- make qmake_all
+ qmake "CONFIG+=system_libpng" "../$_pkgfqn/"
make
}
@@ -32,5 +31,5 @@ package() {
make INSTALL_ROOT="$pkgdir" install
install -D -m644 "../$_pkgfqn/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/system/${pkgname}.rule"
}
diff --git a/qt5-apng-plugin.rule b/qt5-apng-plugin.rule
index 2247db2479b7..2ed9d98d2955 100644
--- a/qt5-apng-plugin.rule
+++ b/qt5-apng-plugin.rule
@@ -1 +1 @@
-qt5-base libpng
+qt5-base=v libpng=v