summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Campello Ferreira2014-05-23 01:58:56 -0300
committerMarcel Campello Ferreira2014-05-23 01:58:56 -0300
commit27ba97771141b5ca58ef3274b6b5e735baa15a74 (patch)
treea6447dce406da19c3e14d82d7111bd45db6a99c6
parentb721fa0969ee8d63e884503e8520fcd3f3f653c9 (diff)
downloadaur-27ba97771141b5ca58ef3274b6b5e735baa15a74.tar.gz
Version 2.0.3-2.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
-rw-r--r--neo4j.install14
-rw-r--r--neo4j.service2
4 files changed, 31 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 767be7c95835..978f1ed780ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = neo4j
pkgdesc = A fully transactional graph database implemented in Java
- pkgver = 2.0.2
- pkgrel = 1
+ pkgver = 2.0.3
+ pkgrel = 2
url = http://neo4j.org/
install = neo4j.install
arch = any
license = GPL
+ makedepends = patch
depends = bash
depends = lsof
- depends = java-runtime
+ depends = java-runtime-headless
options = !strip
backup = etc/neo4j/custom-logback.xml
backup = etc/neo4j/logging.properties
@@ -16,17 +17,17 @@ pkgbase = neo4j
backup = etc/neo4j/neo4j-server.properties
backup = etc/neo4j/neo4j-wrapper.conf
backup = etc/neo4j/neo4j.properties
- source = http://dist.neo4j.org/neo4j-community-2.0.2-unix.tar.gz
+ source = http://dist.neo4j.org/neo4j-community-2.0.3-unix.tar.gz
source = bin.patch
source = conf.patch
source = neo4j.install
source = neo4j.service
source = neo4j-tmpfile.conf
- sha256sums = e137fd4f259c584f4e3ec6ed446031d80e6099874a0b5dec9440bfbb81fdd5c0
+ sha256sums = f7698c0f479bdffc8713d299314a322305cfa094859a88a99b50e8cf3df099e9
sha256sums = 870d0fe93a07053df8edcee32c5638414336116a2a26531fa689e849032fdf9e
sha256sums = 47f7648c0d609d363ae8e4ad5317a7f37f7625c4ac05a356d2d41a9bfbde495a
- sha256sums = 7cec057ea41df6333389ef5d9654fa7769ea141dbe5da5bf1b526c6de292e22f
- sha256sums = 27e044354f10cb4c844b827442850326d900bc40e01443dbc0cd446bd057af27
+ sha256sums = b86e71e80ad7c2e10a095dfd42296c117ffafa10ee1cc923e1072f6d64ac9dfa
+ sha256sums = 9b6438b75b88a89e89751996942c453fb60c6e8b0bd5aa432bbefddc753362d8
sha256sums = e9ecbf86072ca92129ab1889b5f91e2494b86e84248bd15a37681a3997892d7d
pkgname = neo4j
diff --git a/PKGBUILD b/PKGBUILD
index c139f7b3c5d9..03178bde8991 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Marcel Campello Ferreira <tucho.tijucano@gmail.com>
pkgname=neo4j
-pkgver=2.0.2
-pkgrel=1
+pkgver=2.0.3
+pkgrel=2
pkgdesc="A fully transactional graph database implemented in Java"
arch=(any)
url="http://neo4j.org/"
license=(GPL)
-depends=(bash lsof java-runtime)
+makedepends=(patch)
+depends=(bash lsof java-runtime-headless)
backup=(etc/neo4j/custom-logback.xml
etc/neo4j/logging.properties
etc/neo4j/neo4j-http-logging.xml
@@ -21,11 +22,11 @@ source=(http://dist.neo4j.org/neo4j-community-$pkgver-unix.tar.gz
neo4j.install
neo4j.service
neo4j-tmpfile.conf)
-sha256sums=(e137fd4f259c584f4e3ec6ed446031d80e6099874a0b5dec9440bfbb81fdd5c0
+sha256sums=(f7698c0f479bdffc8713d299314a322305cfa094859a88a99b50e8cf3df099e9
870d0fe93a07053df8edcee32c5638414336116a2a26531fa689e849032fdf9e
47f7648c0d609d363ae8e4ad5317a7f37f7625c4ac05a356d2d41a9bfbde495a
- 7cec057ea41df6333389ef5d9654fa7769ea141dbe5da5bf1b526c6de292e22f
- 27e044354f10cb4c844b827442850326d900bc40e01443dbc0cd446bd057af27
+ b86e71e80ad7c2e10a095dfd42296c117ffafa10ee1cc923e1072f6d64ac9dfa
+ 9b6438b75b88a89e89751996942c453fb60c6e8b0bd5aa432bbefddc753362d8
e9ecbf86072ca92129ab1889b5f91e2494b86e84248bd15a37681a3997892d7d)
prepare() {
@@ -69,10 +70,6 @@ package() {
install -dm755 $pkgdir/var/lib/neo4j/data
install -dm755 $pkgdir/var/log/neo4j
- # Documentation files
- install -dm 755 $pkgdir/usr/share/doc/neo4j
- cp -r doc/* $pkgdir/usr/share/doc/neo4j
-
# License files
install -dm755 $pkgdir/usr/share/licenses/neo4j
cp LICENSE.txt LICENSES.txt NOTICE.txt $pkgdir/usr/share/licenses/neo4j
diff --git a/neo4j.install b/neo4j.install
index 97733e3ed09a..a094e1a34578 100644
--- a/neo4j.install
+++ b/neo4j.install
@@ -15,10 +15,13 @@ post_install() {
chown -R neo4j.neo4j /etc/neo4j
/usr/bin/systemd-tmpfiles --create neo4j.conf
+
+ warn_about_java_home
}
post_upgrade() {
assert_user_and_group_exist
+ warn_about_java_home
}
post_remove() {
@@ -29,3 +32,14 @@ post_remove() {
groupdel neo4j
fi
}
+
+warn_about_java_home() {
+ echo "------------------------------"
+ echo "--- ACHTUNG ACHTUNG ALARM! ---"
+ echo "------------------------------"
+ echo "Before starting the Neo4j service, please edit"
+ echo "'/usr/lib/systemd/system/neo4j.service', changing"
+ echo "'Environment=JAVA_HOME=/your/java/home/path' to your"
+ echo "actual JAVA_HOME path. Do not forget to uncomment"
+ echo "that line too and then run 'systemctl daemon-reload'."
+}
diff --git a/neo4j.service b/neo4j.service
index f2f9617d49ac..0b06ec166e16 100644
--- a/neo4j.service
+++ b/neo4j.service
@@ -7,6 +7,8 @@ Type=forking
ExecStart=/usr/bin/neo4j start
ExecStop=/usr/bin/neo4j stop
PIDFile=/run/neo4j/neo4j-service.pid
+LimitNOFILE=40000
+# Environment=JAVA_HOME=/your/java/home/path
[Install]
WantedBy=multi-user.target