summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeke Sonxx2016-08-03 13:25:08 -0400
committerZeke Sonxx2016-08-03 13:25:37 -0400
commit27bce27456ace6363a33c0b0af9c4d2699e702bb (patch)
tree15153887a2f9707ca8773b67cf22c8c607ff3135
parentf489d8b34bbf6ea6451fe0d6a55112222abdbbbc (diff)
downloadaur-27bce27456ace6363a33c0b0af9c4d2699e702bb.tar.gz
Update to 0.1.0-beta; switch to extracting from .deb
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bd8862ec5c9..0699145c480c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = moeditor-bin
pkgdesc = All-purpose markdown editor based on Electrum
- pkgver = 0.0.1_alpha
+ pkgver = 0.1.0_beta
pkgrel = 1
url = https://github.com/Moeditor/Moeditor
arch = x86_64
@@ -11,9 +11,9 @@ pkgbase = moeditor-bin
depends = alsa-lib
depends = nss
depends = gconf
- source = https://github.com/Moeditor/Moeditor/releases/download/v0.0.1-alpha/Moeditor-0.0.1-linux-x64.7z
- md5sums = fe7e9970563f8bfd3e358f5893bdb41a
- sha512sums = 696c91e7dbba2311ba3944cf93c4a3763d6d9a4fb0d5dd74b7fd4733964c272f338398ce00dcf2dcfe73cc906b1be9a914359ac4a4c1547e016912888efd4afe
+ source = https://github.com/Moeditor/Moeditor/releases/download/v0.1.0-beta/moeditor_0.1.0-1_amd64.deb
+ md5sums = 8bb8ca46d63d61ada501a24a951a1c29
+ sha512sums = bf691d4a089271b677b1873046675954cd843d00288de0b6926039ab481341141e0d63e3b198c7f60587740b3718d030d8822b4630c0dea1aab0b5f6861fee38
pkgname = moeditor-bin
diff --git a/.gitignore b/.gitignore
index 129e0a2c33d1..eb7880ae6992 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,4 @@ src/*
# Moeditor source files
*.7z
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
index f6aa9030c400..675d6e544b0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: Zeke Sonxx <zeke@zekesonxx.com>
pkgname=moeditor-bin
-pkgver=0.0.1_alpha
+pkgver=0.1.0_beta
pkgrel=1
epoch=
pkgdesc="All-purpose markdown editor based on Electrum"
@@ -24,13 +24,14 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/Moeditor/Moeditor/releases/download/v0.0.1-alpha/Moeditor-0.0.1-linux-x64.7z")
+# first one changes the _ to -, second one removes the -beta entirely.
+source=("https://github.com/Moeditor/Moeditor/releases/download/v${pkgver//_/-}/moeditor_${pkgver//_beta/}-1_amd64.deb")
noextract=()
-md5sums=('fe7e9970563f8bfd3e358f5893bdb41a')
-sha512sums=('696c91e7dbba2311ba3944cf93c4a3763d6d9a4fb0d5dd74b7fd4733964c272f338398ce00dcf2dcfe73cc906b1be9a914359ac4a4c1547e016912888efd4afe')
+md5sums=('8bb8ca46d63d61ada501a24a951a1c29')
+sha512sums=('bf691d4a089271b677b1873046675954cd843d00288de0b6926039ab481341141e0d63e3b198c7f60587740b3718d030d8822b4630c0dea1aab0b5f6861fee38')
validpgpkeys=()
package() {
- mkdir -p "$pkgdir/usr"
- cp -r "$srcdir/usr/" "$pkgdir/"
+ bsdtar xf data.tar.xz
+ mv usr "$pkgdir"
}