summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-05-27 17:04:30 -0400
committerJean Lucas2018-05-27 17:04:30 -0400
commit27d51302251e3aac018b6483e3f9e3ded9152ab4 (patch)
tree7986ecef6299b43dfba820334911f57ee4f99d8b
parent24002676f9735c3ed8040e97fbb63b02028aa150 (diff)
downloadaur-27d51302251e3aac018b6483e3f9e3ded9152ab4.tar.gz
Version bump to 4.12.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 22 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8836da223d26..864a85c947de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
# Generated by mksrcinfo v8
-# Thu Apr 21 14:01:47 UTC 2016
+# Sun May 27 21:04:10 UTC 2018
pkgbase = python2-humanfriendly
- pkgdesc = Human friendly output for text interfaces using Python
- pkgver = 1.44.7
+ pkgdesc = Human-friendly output for text interfaces using Python
+ pkgver = 4.12.1
pkgrel = 1
- url = https://humanfriendly.readthedocs.org
+ url = https://humanfriendly.readthedocs.io
arch = any
license = MIT
makedepends = python2-setuptools
depends = python2
- provides = humanfriendly
- provides = python2-humanfriendly
- conflicts = humanfriendly
+ depends = python2-monotonic
options = !emptydirs
- source = https://pypi.python.org/packages/05/43/47c39f284391051c503322b86d2ffbe1e7314a3156cf5649aa7af03c85fb/humanfriendly-1.44.7.tar.gz
- md5sums = ead99eb5d8a8416b6b1a1a41892efa06
- sha256sums = fcee758612edc6fead9b8fd1d5a473eab2c3a84cf8766f3ce70862ccd35e8a64
+ source = https://files.pythonhosted.org/packages/8a/17/2f49d6b94908ff21031f2daaac498170e64983ddcc34d8d1becd2c45b03b/humanfriendly-4.12.1.tar.gz
+ sha256sums = 937b4d2c99d29007023ebcab23579429541bfb3357a97e5df38fc5d851a112a3
+ sha512sums = cca8c14b63a7113a06e5f99b5d28ba4228705bfe9b25873f74ac711116fc1b71debd021284573d9cfd41906c825fbf914b779b785359bc9d617f388e5cb633db
pkgname = python2-humanfriendly
diff --git a/PKGBUILD b/PKGBUILD
index 614328f8cd96..eacc98b7b2a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Maintainer: Jean Lucas <jean@4ray.co>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=python2-humanfriendly
-pkgver=1.44.7
+pkgver=4.12.1
pkgrel=1
-pkgdesc="Human friendly output for text interfaces using Python"
-arch=('any')
-depends=('python2')
-makedepends=('python2-setuptools')
-url="https://humanfriendly.readthedocs.org"
-license=('MIT')
+pkgdesc='Human-friendly output for text interfaces using Python'
+arch=(any)
+url='https://humanfriendly.readthedocs.io'
+license=(MIT)
+depends=(python2 python2-monotonic)
+makedepends=(python2-setuptools)
options=(!emptydirs)
-source=(https://pypi.python.org/packages/05/43/47c39f284391051c503322b86d2ffbe1e7314a3156cf5649aa7af03c85fb/${pkgname#python2-}-$pkgver.tar.gz)
-md5sums=('ead99eb5d8a8416b6b1a1a41892efa06')
-sha256sums=('fcee758612edc6fead9b8fd1d5a473eab2c3a84cf8766f3ce70862ccd35e8a64')
-provides=('humanfriendly' 'python2-humanfriendly')
-conflicts=('humanfriendly')
+source=(https://files.pythonhosted.org/packages/8a/17/2f49d6b94908ff21031f2daaac498170e64983ddcc34d8d1becd2c45b03b/humanfriendly-$pkgver.tar.gz)
+sha256sums=(937b4d2c99d29007023ebcab23579429541bfb3357a97e5df38fc5d851a112a3)
+sha512sums=(cca8c14b63a7113a06e5f99b5d28ba4228705bfe9b25873f74ac711116fc1b71debd021284573d9cfd41906c825fbf914b779b785359bc9d617f388e5cb633db)
package() {
- cd "$srcdir/${pkgname#python2-}-$pkgver"
-
- msg2 'Installing...'
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd $srcdir/humanfriendly-$pkgver
+ python2 setup.py install --root=$pkgdir --optimize=1
}