summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav Nepogodin2023-08-25 02:39:25 +0400
committerVladislav Nepogodin2023-08-25 02:39:25 +0400
commit27dbd1b1e357c5bc50ced030c716ec53e827ce1a (patch)
tree435ae3748ab88fd8860cf33612fc912676d4ca8f
parentcf70d15c570df373977177014bb813b00c194cea (diff)
downloadaur-27dbd1b1e357c5bc50ced030c716ec53e827ce1a.tar.gz
disable old system spdlog
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 7 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 828d78b33561..52f30f575b20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ananicy-cpp-git
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = 1.0.1.r12.gcafb692
+ pkgver = 1.1.0.r5.gddbb795
pkgrel = 1
url = https://gitlab.com/ananicy-cpp/ananicy-cpp.git
arch = x86_64
@@ -14,8 +14,6 @@ pkgbase = ananicy-cpp-git
makedepends = nlohmann-json
makedepends = bpf
depends = fmt
- depends = spdlog
- depends = nlohmann-json
depends = systemd
depends = libelf
depends = zlib
@@ -25,8 +23,6 @@ pkgbase = ananicy-cpp-git
provides = ananicy-cpp
conflicts = ananicy-cpp
source = ananicy-cpp::git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git
- source = git+https://gitlab.com/vnepogodin/std-format.git
- sha512sums = SKIP
sha512sums = SKIP
pkgname = ananicy-cpp-git
diff --git a/PKGBUILD b/PKGBUILD
index 65c33089797d..720bbe649056 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,18 @@
_pkgname=ananicy-cpp
pkgname=ananicy-cpp-git
-pkgver=1.0.1.r12.gcafb692
+pkgver=1.1.0.r5.gddbb795
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
arch=(x86_64 i386 armv7h)
url="https://gitlab.com/ananicy-cpp/ananicy-cpp.git"
license=('GPLv3')
-depends=(fmt spdlog nlohmann-json systemd libelf zlib libbpf)
+depends=(fmt systemd libelf zlib libbpf)
makedepends=(cmake ninja clang git nlohmann-json bpf)
optdepends=("ananicy-rules-git: community rules"
"ananicy-rules: Rules based for ananicy-cpp")
-source=("${_pkgname}::git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git"
- "git+https://gitlab.com/vnepogodin/std-format.git")
-sha512sums=('SKIP'
- 'SKIP')
+source=("${_pkgname}::git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git")
+sha512sums=('SKIP')
provides=('ananicy-cpp')
conflicts=('ananicy-cpp')
@@ -26,14 +24,6 @@ pkgver() {
git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "${_pkgname}"
-
- git submodule init
- git config submodule."external/std-format".url "${srcdir}/std-format"
- git -c protocol.file.allow=always submodule update
-}
-
build() {
cd "${srcdir}/${_pkgname}"
@@ -43,11 +33,12 @@ build() {
export CXXFLAGS="${CXXFLAGS}"
export LDFLAGS="${LDFLAGS}"
+ # disable system spdlog
cmake -S . -Bbuild \
-GNinja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DUSE_EXTERNAL_SPDLOG=ON \
+ -DUSE_EXTERNAL_SPDLOG=OFF \
-DUSE_EXTERNAL_JSON=ON \
-DUSE_BPF_PROC_IMPL=ON \
-DBPF_BUILD_LIBBPF=OFF \