summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThayne McCombs2021-07-20 01:06:35 -0600
committerThayne McCombs2021-07-20 01:06:35 -0600
commit27df28050562bc3a1bd833d018e0111fd44dbb1b (patch)
treebcac10cd6af29f92f3b3a886d13136f008e6c426
downloadaur-27df28050562bc3a1bd833d018e0111fd44dbb1b.tar.gz
Initial upload: dbus-term-launcher 0.1.1-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d1e50587ba7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dbus-term-launcher
+ pkgdesc = Wrapper program to launch arbitrary terminal with Terminal intent API
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://gitlab.com/thayne/dbus-term-launcher
+ arch = x86_64
+ license = Apache
+ makedepends = meson
+ depends = glib2
+ optdepends = alacritty: for alacritty launcher
+ optdepends = kitty: for kitty launcher
+ optdepends = xterm: for xterm launcher
+ optdepends = rxvt-unicode: for urxvt launcher
+ source = https://gitlab.com/thayne/dbus-term-launcher/-/archive/0.1.1/dbus-term-launcher-0.1.1.tar.gz
+ sha256sums = 19851c5aa87ec6100fa4adfb55910a1f2832f35db18bf6c1ca21eb851cc974ec
+
+pkgname = dbus-term-launcher
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dae2354ec726
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.zst
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f70a1ffc8594
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thayne McCombs <astrothayne at gmail dot com>
+pkgname=dbus-term-launcher
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Wrapper program to launch arbitrary terminal with Terminal intent API"
+url='https://gitlab.com/thayne/dbus-term-launcher'
+license=(Apache)
+arch=(x86_64)
+depends=(glib2)
+optdepends=('alacritty: for alacritty launcher'
+ 'kitty: for kitty launcher'
+ 'xterm: for xterm launcher'
+ 'rxvt-unicode: for urxvt launcher')
+makedepends=(meson)
+source=(https://gitlab.com/thayne/dbus-term-launcher/-/archive/$pkgver/dbus-term-launcher-$pkgver.tar.gz)
+sha256sums=('19851c5aa87ec6100fa4adfb55910a1f2832f35db18bf6c1ca21eb851cc974ec')
+
+build() {
+ arch-meson $pkgname-$pkgver build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}