summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-08 23:54:33 +0200
committersL1pKn072021-10-08 23:54:33 +0200
commit27eb13962d9d68ca4ed981702c580a45ba5c7b23 (patch)
tree56fc48204b6ed5259dba72d8283b8b79edfba871
downloadaur-27eb13962d9d68ca4ed981702c580a45ba5c7b23.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a6cd9a1dde4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = avisynth-plugin-bifrost-git
+ pkgdesc = Plugin for Avisynth: bifrost (GIT version)
+ pkgver = 2.1.0.1.g31cf836
+ pkgrel = 1
+ url = https://github.com/Asd-g/AviSynth-bifrost
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = avisynthplus
+ provides = avisynth-plugin-bifrost
+ conflicts = avisynth-plugin-bifrost
+ source = bifrost::git+https://github.com/Asd-g/AviSynth-bifrost.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-bifrost-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18ba228e01bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=bifrost
+pkgname=avisynth-plugin-${_plug}-git
+pkgver=2.1.0.1.g31cf836
+pkgrel=1
+pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/Asd-g/AviSynth-bifrost'
+license=('GPL')
+depends=('avisynthplus')
+makedepends=('git'
+ 'cmake'
+ )
+provides=("avisynth-plugin-${_plug}")
+conflicts=("avisynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Asd-g/AviSynth-bifrost.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p "${_plug}/build"
+}
+
+build() {
+ cd "${_plug}/build"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)" cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+}
+
+package(){
+ make -C "${_plug}/build" DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
+}