summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2020-06-19 16:45:17 -0500
committerfrealgagu2020-06-19 16:45:17 -0500
commit28033d9392c3527ea6842b76631946e2cfa0304d (patch)
treec0e4ff40fbb7fac725fb1d6c1e5e84a571f9d209
parentcfa5a07e84f87e41a6ca040a325bfae97219e65f (diff)
downloadaur-28033d9392c3527ea6842b76631946e2cfa0304d.tar.gz
Using the new go package guidelines.
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ece88e2f4053..bfb6fc7f8c04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -86,10 +86,17 @@ prepare() {
build() {
cd "${srcdir}/gopath/src/github.com/zyedidia/${pkgname}"
- GOPATH="${srcdir}/gopath" PATH="${PATH}:${GOPATH}/bin" make build-quick
+ export GOPATH="${srcdir}/gopath"
+ export PATH="${PATH}:${GOPATH}/bin"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw -x -v"
+ make build-quick
# To avoid issues deleting directories next time
- GOPATH="${srcdir}/gopath" go clean --modcache
+ go clean --modcache
}
package() {