summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorergotamin2018-12-19 20:39:05 +0100
committerergotamin2018-12-19 20:39:05 +0100
commit28067816da6b430bdbea18bc6f1f95f557d6e874 (patch)
tree5974555cc01033e10a1e1ba3a5c402aab231415b
parente411c7ccb573b32716e764633de352663d073bdb (diff)
downloadaur-28067816da6b430bdbea18bc6f1f95f557d6e874.tar.gz
updated version, install-script changes
-rw-r--r--PKGBUILD4
-rw-r--r--slimjet-browser.install11
2 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d32f32bb923..0aea5a95ca60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: visit ""
pkgname=('slimjet-browser')
_origname='slimjet'
-pkgver=21.0.4.0
+pkgver=21.0.6.0
pkgrel=1
-pkgdesc="A lightweight Browser based on Blink (**added: 'slim-root' sandbox-user)"
+pkgdesc="A lightweight Browser based on Blink (without setuid-sandbox)"
arch=('x86_64')
url="http://www.slimjet.com"
depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gtk2' 'harfbuzz' 'harfbuzz-icu' 'hicolor-icon-theme' 'xorg-xhost'
diff --git a/slimjet-browser.install b/slimjet-browser.install
index 5660a8b9e340..96d3620880b6 100644
--- a/slimjet-browser.install
+++ b/slimjet-browser.install
@@ -1,14 +1,13 @@
#!/bin/sh
post_install() {
- mkdir -m0755 /home/slim-root || exit 1
- useradd -M -G wheel,http,audio,video,root,sys,mem,utmp --home=/home/slim-root -s /bin/sh slim-root || exit 1
- chown slim-root:root -R /home/slim-root
+ useradd -G root,dbus,wheel,http,network,video,audio \
+ -m -k /dev/zero --comment 'SlimJet runtime' \
+ -s /bin/sh slim-root || exit 1
+ chown slim-root:root -R /home/slim-root || exit 1
chown slim-root:root -R /usr/share/slimjet || exit 1
- setcap cap_setuid,cap_sys_chroot,cap_sys_admin+pei /usr/share/slimjet/slimjet-sandbox || exit 1
- chown root:root /usr/share/slimjet/slimjet-sandbox || exit 1
- chmod 4755 /usr/share/slimjet/slimjet-sandbox || exit 1
}
post_remove() {
userdel --force --remove slim-root || exit 1
+ rm -rf /usr/share/slimjet &>/dev/zero
} \ No newline at end of file