summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz Christ2015-06-15 13:10:59 -0500
committerGötz Christ2015-06-15 13:10:59 -0500
commit2821ba71f564d6fdae6ee509b34ddae0c8281d10 (patch)
tree4e0f3a955cf598cadbaa710e1011781bde11a20c
downloadaur-2821ba71f564d6fdae6ee509b34ddae0c8281d10.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD37
-rw-r--r--smtube-svn.install12
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6e62c49888c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = smtube-svn
+ pkgdesc = Search, download and play videos from YouTube. SVN build.
+ pkgver = 15.5.17.r6953
+ pkgrel = 1
+ url = http://smtube.sourceforge.net
+ install = smtube-svn.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ makedepends = qt5-tools
+ depends = qt5-script
+ depends = qt5-webkit
+ depends = hicolor-icon-theme
+ depends = libxkbcommon-x11
+ optdepends = smplayer: play videos with SMPlayer
+ optdepends = mpv: play videos with mpv
+ optdepends = gnome-mplayer: play videos with GNOME MPlayer
+ optdepends = kdemultimedia-dragonplayer: play videos with Dragon Player
+ optdepends = totem: play videos with Totem
+ optdepends = vlc: play videos with VLC
+ provides = smtube
+ conflicts = smtube
+ source = smtube::svn+https://subversion.assembla.com/svn/smplayer/smtube/trunk/
+ md5sums = SKIP
+
+pkgname = smtube-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..675f4d49d88e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=smtube-svn
+pkgver=15.5.17.r6953
+pkgrel=1
+pkgdesc="Search, download and play videos from YouTube. SVN build."
+arch=('i686' 'x86_64')
+url="http://smtube.sourceforge.net"
+license=('GPL')
+depends=('qt5-script' 'qt5-webkit' 'hicolor-icon-theme' 'libxkbcommon-x11')
+makedepends=('subversion' 'qt5-tools')
+optdepends=('smplayer: play videos with SMPlayer'
+ 'mpv: play videos with mpv'
+ 'gnome-mplayer: play videos with GNOME MPlayer'
+ 'kdemultimedia-dragonplayer: play videos with Dragon Player'
+ 'totem: play videos with Totem'
+ 'vlc: play videos with VLC')
+provides=('smtube')
+conflicts=('smtube')
+install="$pkgname.install"
+source=('smtube::svn+https://subversion.assembla.com/svn/smplayer/smtube/trunk/')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$SRCDEST"/smtube
+ echo $(grep -m1 "VERSION \"" src/version.cpp | cut -d " " -f3 | sed -e 's/^"\(.*\)"$/\1/').r$(svnversion)
+}
+
+build() {
+ cd "$srcdir/smtube"
+ make clean
+ ./get_svn_revision.sh
+ make PREFIX="/usr"
+}
+
+package() {
+ cd "$srcdir/smtube"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+}
diff --git a/smtube-svn.install b/smtube-svn.install
new file mode 100644
index 000000000000..029294d67005
--- /dev/null
+++ b/smtube-svn.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}