summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2021-01-21 18:56:56 +0900
committerhayao2021-01-21 18:56:56 +0900
commit2827581bc84d140981c98a22ca91fb92bc450d38 (patch)
treefb25fd0aa7305e50931dcb4f35b54750f64be97b
parent7ebe35fc44aef74b8bbac982ee2254d64cb39b1d (diff)
downloadaur-2827581bc84d140981c98a22ca91fb92bc450d38.tar.gz
[fix] : Use pulseaudio command
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e439e335480..9fedf576920a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pulseaudio-modules-bt
pkgdesc = PulseAudio Bluetooth modules with SBC, AAC, APTX, APTX-HD, Sony LDAC (A2DP codec) support
pkgver = 1.4_14.2
- pkgrel = 1
+ pkgrel = 5
url = https://github.com/EHfive/pulseaudio-modules-bt
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 8b28116f0a43..731cb920055e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,9 @@
# Contributar: tleydxdy https://aur.archlinux.org/packages/pulseaudio-modules-bt/#comment-786420
get_pulseaudio_version() {
- printf "$(pkg-config libpulse --modversion|sed 's/[^0-9.]*\([0-9.]*\).*/\1/')"
+ #printf "$(pkg-config libpulse --modversion|sed 's/[^0-9.]*\([0-9.]*\).*/\1/')"
+ #printf "$(pacman -Q "$(basename "${pulseaudio_pkgname}")" | cut -d ' ' -f 2 | cut -d '-' -f 1)"
+ printf "$(pulseaudio --version | cut -d " " -f 2)"
}
#-- PulseAudio --#
@@ -13,7 +15,7 @@ pulseaudio_ver="$(get_pulseaudio_version)"
pkgname="pulseaudio-modules-bt"
module_ver="1.4"
pkgver="${module_ver}_${pulseaudio_ver}"
-pkgrel="1"
+pkgrel="5"
pkgdesc="PulseAudio Bluetooth modules with SBC, AAC, APTX, APTX-HD, Sony LDAC (A2DP codec) support"
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
url="https://github.com/EHfive/pulseaudio-modules-bt"