summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-07-01 16:24:03 +0200
committersl1pkn072015-07-01 16:24:03 +0200
commit2852fbdc73d45c9958454f0d6ab76ad7b25a4fdb (patch)
tree9d09f1deb2e8e180be9d8cab0d5e215272dfe990
parentc222a07608b4831949759f8c3f8f5107003fcd76 (diff)
downloadaur-2852fbdc73d45c9958454f0d6ab76ad7b25a4fdb.tar.gz
Update to r16
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4527bb32a60d..be543aeed663 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = vapoursynth-plugin-fmtconv
pkgdesc = Plugin for Vapoursynth: fmtconv
- pkgver = r15
+ pkgver = r16
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=166504
arch = i686
arch = x86_64
license = custom:WTFPL
depends = vapoursynth
- source = http://ldesoras.free.fr/src/vs/fmtconv-r15.zip
- sha1sums = be51f1748ca236c33136d0945cd4f2d3fd012029
+ source = http://ldesoras.free.fr/src/vs/fmtconv-r16.zip
+ sha1sums = 80b90c6404fbfa1a1301993cab069bbe5fed01c8
pkgname = vapoursynth-plugin-fmtconv
diff --git a/PKGBUILD b/PKGBUILD
index 31e180214573..9e865c6d41ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,31 @@
_plug=fmtconv
pkgname=vapoursynth-plugin-${_plug}
-pkgver=r15
+pkgver=r16
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug}"
arch=('i686' 'x86_64')
-url="http://forum.doom9.org/showthread.php?t=166504"
+url='http://forum.doom9.org/showthread.php?t=166504'
license=('custom:WTFPL')
depends=('vapoursynth')
source=("http://ldesoras.free.fr/src/vs/${_plug}-${pkgver}.zip")
-sha1sums=('be51f1748ca236c33136d0945cd4f2d3fd012029')
+sha1sums=('80b90c6404fbfa1a1301993cab069bbe5fed01c8')
prepare() {
rm -fr src/VapourSynth.h
- cd build/unix/
- chmod +x autogen.sh
- ./autogen.sh
+ cd build/unix
+ autoreconf --verbose --install --force
}
build() {
cd build/unix
- CPPFLAGS="${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth)" ./configure --libdir=/usr/lib/vapoursynth
+ CPPFLAGS+=" $(pkg-config --cflags vapoursynth)" ./configure --libdir=/usr/lib/vapoursynth
make
}
package(){
make -C build/unix DESTDIR=${pkgdir} install
- install -d "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/"
- install -m644 "${srcdir}/doc/"*.{png,html,css} "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/"
- install -Dm644 "${srcdir}/doc/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+ (cd doc; for i in *.{html,png,css}; do install -Dm644 "${i}" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/${i}"; done)
+ install -Dm644 doc/license.txt "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
}
-