summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-06-08 12:13:00 +0200
committerwillemw122015-06-08 12:13:00 +0200
commit285dca166d24bbcf91f333af0b327c6821e73738 (patch)
treea493e46b2c3cf25388907d8ed82d498e70010c37
downloadaur-285dca166d24bbcf91f333af0b327c6821e73738.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
-rw-r--r--indicator-weather-bzr.install12
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2896df9adad8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = indicator-weather-bzr
+ pkgdesc = Comprehensive weather notification system, implemented using the indicator applet API (Canonical Ayatana Project)
+ pkgver = r358
+ pkgrel = 3
+ url = https://launchpad.net/weather-indicator
+ install = indicator-weather-bzr.install
+ arch = any
+ license = GPL3
+ makedepends = bzr
+ makedepends = python2-distutils-extra
+ depends = libappindicator-gtk3
+ depends = libgweather
+ depends = python2-pywapi
+ depends = python2-pytz
+ optdepends = python2-unidecode: for ASCII transliterations of Unicode text
+ provides = indicator-weather
+ conflicts = indicator-weather
+ source = indicator-weather-bzr::bzr+http://bazaar.launchpad.net/~weather-indicator-team/weather-indicator/rainy
+ md5sums = SKIP
+
+pkgname = indicator-weather-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98b7113f611d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+_pkgname=indicator-weather
+pkgname=$_pkgname-bzr
+pkgver=r358
+pkgrel=3
+pkgdesc="Comprehensive weather notification system, implemented using the indicator applet API (Canonical Ayatana Project)"
+arch=('any')
+url="https://launchpad.net/weather-indicator"
+license=('GPL3')
+depends=('libappindicator-gtk3' 'libgweather' 'python2-pywapi' 'python2-pytz')
+optdepends=('python2-unidecode: for ASCII transliterations of Unicode text')
+makedepends=('bzr' 'python2-distutils-extra')
+provides=($_pkgname)
+conflicts=($_pkgname)
+install=$pkgname.install
+source=($pkgname::bzr+http://bazaar.launchpad.net/~weather-indicator-team/weather-indicator/rainy) # Series 2.0
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s" "$(bzr revno)"
+}
+
+prepare() {
+ cd $pkgname
+ sed -i "s|share/common-licenses/GPL-3|share/licenses/common/GPL3/license.txt|" bin/indicator-weather
+}
+
+build() {
+ cd $pkgname
+ python2 setup.py build
+}
+
+package() {
+ cd $pkgname
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 AUTHORS "$pkgdir/usr/share/doc/indicator-weather/AUTHORS"
+}
+
diff --git a/indicator-weather-bzr.install b/indicator-weather-bzr.install
new file mode 100644
index 000000000000..f1e02f6b2d52
--- /dev/null
+++ b/indicator-weather-bzr.install
@@ -0,0 +1,12 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+