summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorusrmusicman2020-01-11 23:38:03 -0500
committerusrmusicman2020-01-11 23:38:03 -0500
commit287a51ef3d9bc34a9e0068c7f4f15a0b67dfbab6 (patch)
tree954a019bb05c741d2c5452fa63c2a8e6585180cb
downloadaur-287a51ef3d9bc34a9e0068c7f4f15a0b67dfbab6.tar.gz
Add LinVST3 single wineserver instance variant
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD26
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..027d7795843a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = linvst3x
+ pkgdesc = enables Windows vst3's to be used as Linux vst's in Linux vst capable DAW's (single wineserver instance variant)
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://github.com/osxmidi/LinVst3
+ arch = x86_64
+ makedepends = git
+ depends = wine
+ depends = freetype2
+ depends = xcb-util
+ depends = xcb-util-cursor
+ depends = xcb-util-keysyms
+ depends = libxkbcommon-x11
+ depends = libx11
+ depends = expat
+ depends = gtkmm3
+ depends = sqlite
+ conflicts = linvst3
+ source = https://github.com/osxmidi/LinVst3-X/releases/download/1.7/LinVst3-X-1.7-Manjaro.zip
+ source = git+https://github.com/usrmusicman/ArchStudioUtils.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = linvst3x
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe4138d64da5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer Alex Mcmillan <linuxguy93@gmail.com>
+
+pkgname=linvst3x
+pkgver=1.7
+pkgrel=1
+pkgdesc="enables Windows vst3's to be used as Linux vst's in Linux vst capable DAW's (single wineserver instance variant)"
+arch=('x86_64')
+url="https://github.com/osxmidi/LinVst3"
+depends=('wine' 'freetype2' 'xcb-util' 'xcb-util-cursor' 'xcb-util-keysyms' 'libxkbcommon-x11' 'libx11' 'expat' 'gtkmm3' 'sqlite')
+makedepends=('git')
+conflicts=('linvst3')
+source=("https://github.com/osxmidi/LinVst3-X/releases/download/1.7/LinVst3-X-${pkgver}-Manjaro.zip"
+ "git+https://github.com/usrmusicman/ArchStudioUtils.git")
+sha256sums=('SKIP'
+ 'SKIP')
+
+package() {
+ cd "${srcdir}/LinVst3-X-${pkgver}-Manjaro/embedded/"
+ for file in *.so; do
+ install -Dm755 $file $pkgdir/usr/bin/$file
+ done
+ for file in *.exe; do
+ install -Dm755 $file $pkgdir/usr/bin/$file
+ done
+ install -Dm755 $srcdir/ArchStudioUtils/w2lvst3_X $pkgdir/usr/bin/w2lvst3_X
+}