summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlxgr2020-12-29 17:17:11 +0100
committerlxgr2020-12-29 17:17:11 +0100
commit2883ec150300938fbb8e0cb8bd14c5f2c4484a4f (patch)
treed5f7cfd2cff581d469be4a297f4a01b55b8fa899
downloadaur-2883ec150300938fbb8e0cb8bd14c5f2c4484a4f.tar.gz
35.382fb84
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7a29ef7071d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = almh-git
+ pkgdesc = Gives you a CLI menu with some common maintenance options inside an Arch Linux system
+ pkgver = 35.382fb84
+ pkgrel = 1
+ url = https://github.com/voider755/almh
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = sudo
+ optdepends = newsboat: News support
+ optdepends = pacman-contrib: For options 3 and 7
+ source = almh-git::git+https://github.com/voider755/almh
+ md5sums = SKIP
+
+pkgname = almh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..722d484efe3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: voider755 <voider (at) disroot.org>
+# AUR Package Maintainer: lxgr <lxgr@protonmail.com>
+
+pkgname=almh-git
+pkgver=35.382fb84
+pkgrel=1
+pkgdesc="Gives you a CLI menu with some common maintenance options inside an Arch Linux system"
+arch=(any)
+url="https://github.com/voider755/almh"
+license=('BSD')
+depends=('python' 'sudo')
+makedepends=('git')
+optdepends=("newsboat: News support" "pacman-contrib: For options 3 and 7")
+source=("$pkgname"::'git+https://github.com/voider755/almh')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+package() {
+ cd "${srcdir}/$pkgname"
+ install -Dm0755 -t "$pkgdir/usr/bin" "almh.py"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}